郑州轻工业大学2020年数据结构练习集-7-2 Reversing Linked List (25分)(python)

7-2 Reversing Linked List (25分)

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10​5​​) which is the total number of nodes, and a positive K (≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

Sample Output:

00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

用python的话会超时。

# -*- coding: utf-8 -*-
# @Author: wfy
# @Date:   2020-02-24 10:02:00
# @Last Modified by:   wfy
# @Last Modified time: 2020-02-27 14:54:55
first, n, k = input().split()
l1 = [0 for i in range(500000)]
d = {}


def get_index(x):
    for i in range(0, 3 * int(n), 3):
        if l1[i] == x:
            return i


le = 0
for _ in range(int(n)):
    address, data, next = input().split()
    l1[le] = address
    l1[le + 1] = data
    l1[le + 2] = next
    le += 3
    d[address] = data
next = first
pre_next = []
ans = []
while next != "-1":
    pre_next.append(next)
    i = get_index(next)
    next = l1[i + 2]
    if len(set(pre_next)) == int(k):
        for start in range(int(k) - 1, -1, -1):
            ans.append(pre_next[start])
        pre_next.clear()
for i in range(0, len(pre_next)):
    ans.append(pre_next[i])
for i in range(0, len(ans) - 1):
    print(ans[i], d[ans[i]], ans[i + 1])
print(ans[-1], d[ans[-1]], "-1")

下面转载一个同校大佬的c++题解

https://blog.csdn.net/weixin_44070289/article/details/104517309?depth_1-utm_source=distribute.pc_relevant.none-task&utm_source=distribute.pc_relevant.none-task

#include<bits/stdc++.h>

using namespace std;
const int N = 1e5+10;
struct node
{
    int Address, Data, Next;
}a[N];
vector<node> ans;
int main()
{
    int head,n,k;
    scanf("%d%d%d", &head, &n, &k);
    for(int i = 0; i < n; ++i) {
        int u, v, w;scanf("%d%d%d", &u, &v, &w);
        a[u].Address = u, a[u].Data = v, a[u].Next = w;
    }
    while(head!=-1) {ans.push_back(a[head]); head = a[head].Next;}
    n = ans.size();
    for(int i = 0; i+k-1 < n; i+=k) reverse(ans.begin()+i, ans.begin()+i+k);
    for(int i = 0; i < n; ++i) {
        printf("%05d %d ", ans[i].Address, ans[i].Data);
        (i == n-1) ? printf("-1\n") : printf("%05d\n", ans[i+1].Address);
    }
    return 0;
}

发布了67 篇原创文章 · 获赞 22 · 访问量 7185

猜你喜欢

转载自blog.csdn.net/weixin_43906799/article/details/104536556