PAT-2019年冬季考试-甲级 7-2 Block Reversing

7-2 Block Reversing (25分)

Given a singly linked list L. Let us consider every K nodes as a block (if there are less than K nodes at the end of the list, the rest of the nodes are still considered as a block). Your job is to reverse all the blocks in L. For example, given L as 1→2→3→4→5→6→7→8 and K as 3, your output must be 7→8→4→5→6→1→2→3.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10​5​​) which is the total number of nodes, and a positive K (≤N) which is the size of a block. The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 8 3
71120 7 88666
00000 4 99999
00100 1 12309
68237 6 71120
33218 3 00000
99999 5 68237
88666 8 -1
12309 2 33218

Sample Output:

71120 7 88666
88666 8 00000
00000 4 99999
99999 5 68237
68237 6 00100
00100 1 12309
12309 2 33218
33218 3 -1

 Solution:

这题和 PAT乙级 1025 反转链表 十分相似。

考场偷了点懒,用哈希做了值到地址的映射,正因为如此也避开了野节点的坑点~

#include <bits/stdc++.h>
using namespace std;

const int maxn = 1e6 + 10;
struct node { int data, next; } nodes[maxn];
vector<int> bef, aft;
unordered_map<int, int> m;

inline const int read()
{
    int x = 0, f = 1; char ch = getchar();
    while (ch < '0' || ch > '9') { if (ch == '-') f = -1; ch = getchar(); }
    while (ch >= '0' && ch <= '9') { x = (x << 3) + (x << 1) + ch - '0'; ch = getchar(); }
    return x * f;
}

int main()
{
    int first = read(), n = read(), k = read();
    for (int i = 0; i < n; i++)
    {
        int add, data, next;
        scanf("%d%d%d", &add, &data, &next);
        nodes[add].data = data;
        nodes[add].next = next;
        m[data] = add;
    }
    for (int i = first; i != -1; i = nodes[i].next) bef.push_back(nodes[i].data);
    int size = (int)bef.size();
    for (int i = size - size % k; i < size; i++) aft.push_back(bef[i]);
    for (int i = size - size % k - k; i >= 0; i -= k)
        for (int j = 0; j < k; j++)
            aft.push_back(bef[i + j]);
    size = (int)aft.size();
    for (int i = 0; i < size; i++)
    {
        int val = aft[i];
        if (i) printf("%05d\n", m[val]);
        printf("%05d %d ", m[val], val);
    }
    printf("-1\n");
    return 0;
}
发布了367 篇原创文章 · 获赞 148 · 访问量 2万+

猜你喜欢

转载自blog.csdn.net/qq_35850147/article/details/103440573
今日推荐