17年冬季第一题 PAT甲级 1140 Look-and-say Sequence (20分)

原题

Look-and-say sequence is a sequence of integers as the following:

D, D1, D111, D113, D11231, D112213111, ...

where D is in [0, 9] except 1. The (n+1)st number is a kind of description of the nth number. For example, the 2nd number means that there is one D in the 1st number, and hence it is D1; the 2nd number consists of one D (corresponding to D1) and one 1 (corresponding to 11), therefore the 3rd number is D111; or since the 4th number is D113, it consists of one D, two 1's, and one 3, so the next number must be D11231. This definition works for D = 1 as well. Now you are supposed to calculate the Nth number in a look-and-say sequence of a given digit D.

Input Specification:

Each input file contains one test case, which gives D (in [0, 9]) and a positive integer N (≤ 40), separated by a space.

Output Specification:

Print in a line the Nth number in a look-and-say sequence of D.

Sample Input:

1 8

Sample Output:

1123123111

易错点

生成的序列并不是统计全局的计数,而是look and say,就地处理。

代码

#include<iostream>
#include<vector>
#include<set>
#include<map>
#include<algorithm>
#include<cmath>
using namespace std;
int main(){
    int d,n;
    cin>>d>>n;
    string s=to_string(d);
    for(int i=0;i<n-1;i++){
        int len=s.size(),same=1;
        string t="";
        for(int j=0;j<len;j++){
            if(j+1<len){
                if(s[j]==s[j+1]){
                    same++;
                }else {
                    t+=s[j];
                    t+=to_string(same);
                    same=1;
                }
            }else {
                t+=s[j];
                t+=to_string(same);
            }
            
        }
        s=t;

    }
    cout<<s<<endl;
    return 0;
}
发布了21 篇原创文章 · 获赞 1 · 访问量 1179

猜你喜欢

转载自blog.csdn.net/allisonshing/article/details/104215950