【笨方法学PAT】1140 Look-and-say Sequence (20 分)

版权声明:欢迎转载,请注明来源 https://blog.csdn.net/linghugoolge/article/details/84235339

一、题目

Look-and-say sequence is a sequence of integers as the following:

D, D1, D111, D113, D11231, D112213111, ...

where D is in [0, 9] except 1. The (n+1)st number is a kind of description of the nth number. For example, the 2nd number means that there is one D in the 1st number, and hence it is D1; the 2nd number consists of one D (corresponding to D1) and one 1 (corresponding to 11), therefore the 3rd number is D111; or since the 4th number is D113, it consists of one D, two 1's, and one 3, so the next number must be D11231. This definition works for D = 1 as well. Now you are supposed to calculate the Nth number in a look-and-say sequence of a given digit D.

Input Specification:

Each input file contains one test case, which gives D (in [0, 9]) and a positive integer N (≤ 40), separated by a space.

Output Specification:

Print in a line the Nth number in a look-and-say sequence of D.

Sample Input:

1 8

Sample Output:

1123123111

二、题目大意

给定数字和规则,求序列。

三、考点

找规律

四、注意

1、循环的时候注意++和截止条件。

五、代码

#include<iostream>
#include<string>
#include<vector>
using namespace std;
int main() {
	//read
	string d;
	int n;
	cin >> d >> n;
	vector<string> v(n);

	v[0] = d;
	for (int i = 1; i < n; ++i) {
		for (int j = 0; j < v[i - 1].size(); ) {
			char c = v[i - 1][j];
			int num = 0;
			while (j < v[i - 1].size() && c == v[i - 1][j]) {
				j++;
				num++;
			}
			v[i] += c;
			v[i] += to_string(num);
		}
	}

	cout << v[n - 1];

	system("pause");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/linghugoolge/article/details/84235339