1140 Look-and-say Sequence (20分)

Look-and-say sequence is a sequence of integers as the following:

D, D1, D111, D113, D11231, D112213111, ...

where D is in [0, 9] except 1. The (n+1)st number is a kind of description of the nth number. For example, the 2nd number means that there is one D in the 1st number, and hence it is D1; the 2nd number consists of one D (corresponding to D1) and one 1 (corresponding to 11), therefore the 3rd number is D111; or since the 4th number is D113, it consists of one D, two 1's, and one 3, so the next number must be D11231. This definition works for D = 1 as well. Now you are supposed to calculate the Nth number in a look-and-say sequence of a given digit D.

Input Specification:

Each input file contains one test case, which gives D (in [0, 9]) and a positive integer N (≤40), separated by a space.

Output Specification:

Print in a line the Nth number in a look-and-say sequence of D.

Sample Input:

1 8

Sample Output:

1123123111
#include<iostream>
#include<vector>
#include<cstdlib>
using namespace std;

int main(){

    int d, n;
    cin >> d >> n;

    string s = to_string(d);

    for(int j = 0; j < n - 1; j++){

        string temp_s = "";
        char c = s[0];
        int count = 1;
        for(int i = 1; i < s.size(); i++){
            
            if(c == s[i]){
                count++;
            }else
            {
                // cout << c << " " << count << endl;
                temp_s += c;
                temp_s += to_string(count);
                count = 1;
                c = s[i];
            }
            


        }

        // cout << c << " " << count << endl;

        temp_s += c;
        temp_s += to_string(count);
        s = temp_s;

    

    }
    
    cout << s << endl;

 





    


    return 0;
}
发布了32 篇原创文章 · 获赞 0 · 访问量 432

猜你喜欢

转载自blog.csdn.net/zbchenchanghao/article/details/104077843