PAT Advanced 1140. Look-and-say Sequence (20)

问题描述:

1140. Look-and-say Sequence (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Look-and-say sequence is a sequence of integers as the following:

D, D1, D111, D113, D11231, D112213111, ...

where D is in [0, 9] except 1. The (n+1)st number is a kind of description of the nth number. For example, the 2nd number means that there is one D in the 1st number, and hence it is D1; the 2nd number consists of one D (corresponding to D1) and one 1 (corresponding to 11), therefore the 3rd number is D111; or since the 4th number is D113, it consists of one D, two 1's, and one 3, so the next number must be D11231. This definition works for D = 1 as well. Now you are supposed to calculate the Nth number in a look-and-say sequence of a given digit D.

Input Specification:

Each input file contains one test case, which gives D (in [0, 9]) and a positive integer N (<=40), separated by a space.

Output Specification:

Print in a line the Nth number in a look-and-say sequence of D.

Sample Input:
1 8
Sample Output:
1123123111

纪念一下3月18日PAT满分×1

这一题关键是要理解题意,理解后就不难了。。。

AC代码:

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
#include<bits/stdc++.h>
using namespace std;
int main()
{
//	freopen("data1.txt","r",stdin);
	ios::sync_with_stdio(false);
	vector<int> v;
	int n,m;
	cin>>n>>m;
	m--;
	v.push_back(n);
	for(;m--;)
	{
		vector<int> v0;
		int v00=v[0];
		int ii=1;
		for(int i=1;i<v.size();i++)
		{
			if(v[i]!=v00)
			{
				v0.push_back(v00);
				v0.push_back(ii);
				v00=v[i];
				ii=1;

			}
			else
			ii++;
		}
		v0.push_back(v00);
		v0.push_back(ii);
		v=v0;
	}
	for(auto i:v)
	cout<<i;
	return 0;
}

猜你喜欢

转载自blog.csdn.net/baidu_37550206/article/details/79605381