[Python](PAT)1140 Look-and-say Sequence(20 分)

版权声明:首发于 www.amoshuang.com https://blog.csdn.net/qq_35499060/article/details/82079029

Look-and-say sequence is a sequence of integers as the following:

D, D1, D111, D113, D11231, D112213111, ...

where D is in [0, 9] except 1. The (n+1)st number is a kind of description of the nth number. For example, the 2nd number means that there is one D in the 1st number, and hence it is D1; the 2nd number consists of one D (corresponding to D1) and one 1 (corresponding to 11), therefore the 3rd number is D111; or since the 4th number is D113, it consists of one D, two 1's, and one 3, so the next number must be D11231. This definition works for D = 1 as well. Now you are supposed to calculate the Nth number in a look-and-say sequence of a given digit D.

Input Specification:

Each input file contains one test case, which gives D (in [0, 9]) and a positive integer N (≤ 40), separated by a space.

Output Specification:

Print in a line the Nth number in a look-and-say sequence of D.

Sample Input:

1 8

Sample Output:

1123123111

题目大意

给定D和N,要求输出N次之后对D的描述。

描述方法为:

1

11                    上一个数包含1,且只有1个

12                   上一个数包含1,且有2个

1121                上一个数包含1,有1个;包含2,有1个

122111            上一个数包含1,有2个;包含2,有1个;包含1,有1个

112213            上一个数包含1,有1个;包含2,有2个;包含1,有3个

。。。。。。。。。。。。。。。。。。。

分析

使用递归的describe函数进行描述,当进入最后一次描述时,返回结果。

每次进行描述的时候,从0开始遍历整个字符串,遇到第一个不相同的字符时,完成前面的字符描述。要注意遇上最后一个字符的时候,要进行描述并结束。

Python实现

def describe(d, k):
    if k == 1:
        return d
    else:
        temp, start = '', 0
        for x in range(len(d)):
            if d[x] != d[start]:
                temp = temp + d[start] + str(x - start)
                start = x
            if x == len(d) -1:
                temp = temp + d[start] + str(x - start + 1)
        return describe(temp, k - 1)

if __name__ == "__main__":
    line = input().split(" ")
    result = describe(line[0], int(line[1]))
    print(result)

猜你喜欢

转载自blog.csdn.net/qq_35499060/article/details/82079029