PAT Look-and-say Sequence(20 分)

Look-and-say sequence is a sequence of integers as the following:

D, D1, D111, D113, D11231, D112213111, ...

where D is in [0, 9] except 1. The (n+1)st number is a kind of description of the nth number. For example, the 2nd number means that there is one D in the 1st number, and hence it is D1; the 2nd number consists of one D (corresponding to D1) and one 1 (corresponding to 11), therefore the 3rd number is D111; or since the 4th number is D113, it consists of one D, two 1's, and one 3, so the next number must be D11231. This definition works for D = 1 as well. Now you are supposed to calculate the Nth number in a look-and-say sequence of a given digit D.

Input Specification:

Each input file contains one test case, which gives D (in [0, 9]) and a positive integer N (≤ 40), separated by a space.

Output Specification:

Print in a line the Nth number in a look-and-say sequence of D.

Sample Input:

1 8

Sample Output:

1123123111

程序:

#include <cstdio>
#include <iostream>
#include <vector>
using namespace std;
int main()
{
  int d,n;
  scanf("%d%d",&d,&n);
  vector<int> v;
  v.push_back(d);
  for(int i = 1; i < n; i++)
  {
    vector<int> temp;
    temp.push_back(v[0]);
    int count = 1;
    for(int j = 1; j < v.size(); j++)
    {
      if(v[j] == v[j-1])
        count++;
      else
      {
        temp.push_back(count);
        temp.push_back(v[j]);
        count = 1;
      }
    }
    temp.push_back(count);
    v.clear();
    v = temp;
    temp.clear();
  }
  for(int i = 0; i < v.size(); i++)
  {
    printf("%d",v[i]);
  }
  return 0;
}

猜你喜欢

转载自blog.csdn.net/hickey_chen/article/details/81094577
今日推荐