【PAT】1140 Look-and-say Sequence 最后一个测试点超时问题

1140 Look-and-say Sequence

Look-and-say sequence is a sequence of integers as the following:
D, D1, D111, D113, D11231, D112213111, …
where D is in [0, 9] except 1. The (n+1)st number is a kind of description of the nth number. For example, the 2nd number means that there is one D in the 1st number, and hence it is D1; the 2nd number consists of one D (corresponding to D1) and one 1 (corresponding to 11), therefore the 3rd number is D111; or since the 4th number is D113, it consists of one D, two 1’s, and one 3, so the next number must be D11231. This definition works for D = 1 as well. Now you are supposed to calculate the Nth number in a look-and-say sequence of a given digit D.

Input Specification:

Each input file contains one test case, which gives D (in [0, 9]) and a positive integer N (<=40), separated by a space.

Output Specification:

Print in a line the Nth number in a look-and-say sequence of D.

Sample Input:

1 8

Sample Output:

1123123111

思想:就是暴力枚举,这个没有啥思维就是考察编码水平。最后一个测试点我一开始居然超时了,后来发现下面两条语句含义是一样,但是效率却不同,使用上面一条语句进行字符串累加时,最后一个测试点就超时了,但是使用下面一条语句测试点却没有超时。现在还不知道原理是啥,希望找到原理的小伙伴能够给我个链接。

D_temp = D_temp + temp + to_string(sum);
D_temp += temp + to_string(sum);

超时代码:

#include<bits/stdc++.h>
using namespace std;
int main() {
	string D,D_temp=""; int N;
 	cin >> D; scanf("%d", &N);
	for (int i = 0; i < N-1; i++) {
		//string D_temp;
		int sum = 1; char temp = D[0];
		int len = D.length();
		for (int j = 1; j < len; j++) {
			if (temp == D[j]) sum++;
			else{
				D_temp = D_temp + temp + to_string(sum);
				temp = D[j];
				sum = 1;
			}
		}
		D_temp = D_temp + temp + to_string(sum);
		D = D_temp;
		D_temp = "";
	}
	printf("%s", D.c_str());
}

AC代码:

#include<bits/stdc++.h>
using namespace std;
int main() {
	string D,D_temp=""; int N;
 	cin >> D; scanf("%d", &N);
	for (int i = 0; i < N-1; i++) {
		int sum = 1; char temp = D[0];
		int len = D.length();
		for (int j = 1; j < len; j++) {
			if (temp == D[j]) sum++;
			else{
				D_temp += temp + to_string(sum);
				temp = D[j];
				sum = 1;
			}
		}
		D_temp += temp + to_string(sum);
		D = D_temp;
		D_temp = "";
	}
	printf("%s", D.c_str());
}

猜你喜欢

转载自blog.csdn.net/qq_39072627/article/details/107384437