Arbitrage POJ - 2240

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.  

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.  
Input
The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.  
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.
Output
For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".
Sample Input
3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0
Sample Output
 
 

Case 1: Yes Case 2: No


思路:只要是经过许多边能让其值大于1,就说明可以套汇,因此可以使用类似于最短路的算法,求最大汇率,bellman-ford.每次往大的松弛的。
#include<iostream>
#include<map>
#include<algorithm>
#include<cstring>
using namespace std;
map<string, int>q;
const int maxn = 1000;
const int INF = 0x3f3f3f3f;
int n, m;
double rate;
char str[55], str1[55], str2[55];
double d[maxn][maxn];
void floyd()
{
 for (int k = 1; k <= n; k++)
 {
  for (int i = 1; i <= n; i++)
  {
   for (int j = 1; j <= n; j++)
   {
    if (d[i][j] < d[i][k] * d[k][j])
     d[i][j] = d[i][k] * d[k][j];
   }
  }
 }
}
int main()
{
 while (1)
 {
  memset(d, INF, sizeof(d));
  cin >> n ;
  for (int i = 1; i <= n; i++)
  {
   cin >> str;
   q[str] = i;
   d[i][i] = 1;
  }
  cin >> m;
  for (int i = 1; i <= m; i++)
  {
   cin >> str1 >> rate >> str2;
   d[q[str1]][q[str2]] = rate;
  }
  floyd();
  int flag = false;
  for (int i = 1; i <= n; i++)
  {
   if (d[i][i] > 1)
   {
    flag = true;
    break;
   }
  }
  if (flag)
   printf("true\n");
  else
   printf("false\n");
 }
 return 0;
}

猜你喜欢

转载自blog.csdn.net/yihanyifan/article/details/80112691