POJ 2240 (判环)

Arbitrage

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 27147   Accepted: 11426

Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent. 

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not. 

Input

The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible. 
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".

Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

Sample Output

Case 1: Yes
Case 2: No

题意: 给你一些 钱 进行汇率转化。问经过一系列转化之后, 你的钱会不会变多。

思路: spfa 判环(和判负环一样的思路), 记录每个点的入队次数, 如果某个点入队次数  >= n 则含环。

AC代码:

#include<cstdio>
#include<cstring>
#include<string>
#include<map>
#include<queue>
#include<iostream>
#include<vector>
using namespace std;

double hl[35][35];
double d[35];
int vis[35];
int cnt[35];
int n;

bool spfa(int s){
    memset(vis,0,sizeof(vis));
    memset(cnt,0,sizeof(cnt));
    memset(d,0,sizeof(d));
    d[s] = 100; vis[s] = 1;
    cnt[s] ++;
    queue<int> Q;
    Q.push(s);
    while(!Q.empty()){
        int now = Q.front();
        Q.pop();
        vis[now] = 0;
        for(int i = 1;i <= n ;i ++){
            if(d[i] < d[now] * hl[now][i]){
                d[i] = d[now] * hl[now][i];
                if(!vis[i]){
                    vis[i] = 1;
                    Q.push(i);
                    cnt[i] ++;
                    if(cnt[i] >= n) return 1;
                }
            }
        }
    }
    return 0;
}

int main()
{
    int Case = 1;
    while(~scanf("%d",&n)){
        if(! n) break;
        memset(hl,-1,sizeof(hl));
        map<string,int>mp;
        string name;
        for(int i = 1;i <= n;i ++){
            cin >> name;
            mp[name] = i;
        }
        int m; scanf("%d",&m);
        string a,b; double k;
        for(int i = 0;i < m;i ++){
            cin >> a >> k >> b;
            int u = mp[a],v = mp[b];
            hl[u][v] = k;
        }
        int flag = 0;
        for(int i = 1;i <= n;i ++)
            if(spfa(i)){
                flag = 1;
                break;
            }
        printf("Case %d: ",Case ++);
        if(flag) printf("Yes\n");
        else printf("No\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/no_O_ac/article/details/81277004
今日推荐