poj 2240 Arbitrage【flyod算法】

版权声明:转载的时候记着点个赞再评论一下! https://blog.csdn.net/LOOKQAQ/article/details/82833544

题目链接:http://poj.org/problem?id=2240

Memory Limit: 65536K
Total Submissions: 28255   Accepted: 11842

Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent. 

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not. 

Input

The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible. 
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".

Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

Sample Output

Case 1: Yes
Case 2: No

题意:兑换比率,如果一种货币通过中介最终能换的更高的本身货币,输出Yes,否则输出No!

思路:flyod算法复杂度还是有点高啊,不过这道题还是可以过!

flyod代码:

#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
const int maxn = 100;
double map1[maxn][maxn];
char s[maxn][maxn];
int n,m,t1=1,x,y,ans;
void floyd()  //floyd算法
{
    for(int k=1;k<=n;k++)
    {
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                if(map1[i][j] < map1[i][k]*map1[k][j])
                    map1[i][j] = map1[i][k]*map1[k][j];
            }
        }
    }
    for(int i=1;i<=n;i++) //进行判断
    {
        if(map1[i][i] > 1.0) //如果符合这个关系,说明能成立
        {
            ans = 1;
            break;
        }
    }

}
int main()
{
    ios::sync_with_stdio(false);
    while(cin>>n && n!=0)
    {
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                if(i==j) map1[i][j] = 1.0; //自己转化为自己,汇率为1
                else map1[i][j] = 0; //否则,初始化汇率为0
            }
        }
        for(int i=1;i<=n;i++)
        {
            cin>>s[i];  //输入字符串
        }
        cin>>m;
        double c;
        char a[maxn],b[maxn];
        for(int i=1;i<=m;i++)
        {
            cin>>a>>c>>b;
            for(int j=1;j<=n;j++)  //注意这一步的转化,很重要,将字符串转化为数字
            {
                if(strcmp(s[j],a)==0)
                {
                    x = j;
                    break;
                }
            }
            for(int j=1;j<=n;j++)
            {
                if(strcmp(s[j],b)==0)
                {
                    y = j;
                    break;
                }
            }
            map1[x][y] = c; //如果有符合要求,则初始化该处的值
        }
        ans = 0;
        floyd();
        if(ans==1)
            cout<<"Case "<<t1++<<": "<<"Yes"<<endl;
        else
            cout<<"Case "<<t1++<<": "<<"No"<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/LOOKQAQ/article/details/82833544