POJ2240 Arbitrage【判断正环的存在】

Arbitrage

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 28447   Accepted: 11926

Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent. 

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not. 

Input

The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible. 
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".

Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

Sample Output

Case 1: Yes
Case 2: No

Source

Ulm Local 1996

问题链接:POJ2240 Arbitrage

问题描述 :假设:1美元可以换0.5英镑,1英镑可以换10法郎,1法郎可以换0.21美元。那么1美元经过交换1*0.5*10*0.21=1.05。比本金多了,现在给你n中货币,m种兑换方法,如果存在上述情况则返回YES,否则返回NO。

解题思路:判断是否有正环,使用Bellman_ford算法,只要修改松弛条件和初始化就可以了

AC的C++程序:

#include<iostream>
#include<cstring>
#include<string>
#include<map>

using namespace std;

const int N=10000;
double dist[35];
int n,m;
struct Edge{
	int start,end;
	double w;
}edge[N];

//判断是否有负环 n个结点,m条边 
bool Bellman_ford()
{
	memset(dist,0,sizeof(dist));
	dist[1]=1;
	//进行n-1次松弛
	for(int i=1;i<n;i++)
	  for(int j=0;j<m;j++)
	    if(dist[edge[j].end]<dist[edge[j].start]*edge[j].w) 
	    	dist[edge[j].end]=dist[edge[j].start]*edge[j].w;
	//判断是否有正环
	for(int j=0;j<m;j++)
	    if(dist[edge[j].end]<dist[edge[j].start]*edge[j].w) 
	      return true;
	return false;
}

int main()
{
	string s,from,to;
	int cnt=0;
	double c;
	map<string,int>id;
	while(cin>>n&&n){
		for(int i=1;i<=n;i++){
			cin>>s;
			id[s]=i;
		}
		cin>>m;
		for(int i=0;i<m;i++){
			cin>>from>>c>>to;
			edge[i].start=id[from],edge[i].end=id[to],edge[i].w=c;
		}
		cout<<"Case "<<++cnt<<": ";
		if(Bellman_ford())
		  cout<<"Yes"<<endl;
		else
		  cout<<"No"<<endl; 
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/SongBai1997/article/details/83186846