Arbitrage

                                                             Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
 

Problem Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent. 

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.

Input

The input file will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n. 

Output

For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No". 

Sample Input

 

3 USDollar BritishPound FrenchFranc 3 USDollar 0.5 BritishPound BritishPound 10.0 FrenchFranc FrenchFranc 0.21 USDollar 3 USDollar BritishPound FrenchFranc 6 USDollar 0.5 BritishPound USDollar 4.9 FrenchFranc BritishPound 10.0 FrenchFranc BritishPound 1.99 USDollar FrenchFranc 0.09 BritishPound FrenchFranc 0.19 USDollar 0

Sample Output

 

Case 1: Yes Case 2: No

题意:给出一些货币和货币之间的兑换比率,问是否可以使某种货币经过一些列兑换之后,货币值增加。举例说就是1美元经过一些兑换之后,超过1美元。可以输出Yes,否则输出No。

分析:由于给出的是货币名称,所以首先我们要把货币之间的关系转化成一张图。转化时,听说用STL里面的map很方便,但因为对map不熟悉,所以用的字符串比较。另外,由于Dijkstra算法不能处理带有负权值的最短路,但此题中,两种货币之间的兑换比率可能小于1,相当于这条路径的权值为负。我用了SPFA算法。


#include<stdio.h>

#include<string.h>

#include<queue>

using namespace std;

 

const int N = 35;

int n, m;

double  d[N], Map[N][N];

struct A

{

    char name[100];

}a[35];

 

int Find(char *s)

{

    for(int i = 0; i < n; i++)

        if(strcmp(a[i].name, s) == 0)

            return i;

}

 

int SPFA(int start)

{

    queue<int> q;

    bool inq[N];

    for(int i = 0; i < n; i++)

        d[i] = 0;

    memset(inq, 0, sizeof(inq));

    while(!q.empty())

        q.pop();

    d[start] = 1;

    inq[start] = 1;

    q.push(start);

    while(!q.empty())

    {

        int x = q.front(); 

        q.pop();

        inq[x] = false;

        for(int i = 0; i < n; i++)

        {

            if(d[i] < d[x] * Map[x][i])

            {

                d[i] = d[x] * Map[x][i];

                if(d[start] > 1.0)

                    return 1;

                if(!inq[i])

                {

                    inq[i] = true;

                    q.push(i);

                }

            }

        }

    }

    return 0;

}

 

int main()

{

    int i, j, cas = 0;

    char s1[35], s2[35];

    double s;

    while(~scanf("%d",&n) && n)

    {

        for(i = 0; i < n; i++)

        {

            for(j = 0; j < n; j++)

            {

                if(i == j)

                    Map[i][j] = 1;

                else

                    Map[i][j] = 0;

            }

        }

        for(i = 0; i < n; i++)

            scanf("%s",a[i].name);

        scanf("%d",&m);

        for(i = 0; i < m; i++)

        {

            scanf("%s%lf%s",s1, &s, s2);

            int u = Find(s1), v = Find(s2);

            Map[u][v] = s;

        }

        int flag = 0;

        for(i = 0; i < n; i++)

        {

            if(SPFA(i) == 1)

            {

                flag = 1;

                break;

            }

        }

        printf("Case %d: ",++cas);

        printf("%s\n", flag ? "Yes" : "No");

    }

    return 0;

}

这两天又学习了Floyd和Bellman-Ford算法,又写了一遍,并用到了map容器。
Floyd算法:


#include<stdio.h>

#include<string.h>

#include<map>

#include<string>

using namespace std;

double Map[35][35];

int n, m;

 

void Init()

{

    for(int i = 1; i <= n; i++)

        for(int j = 1; j <= n; j++)

        {

            if(i == j)

                Map[i][j] = 1;

            else

                Map[i][j] = 0;

        }

}

 

void Floyd()

{

    for(int k = 1; k <= n; k++)

        for(int i = 1; i <= n; i++)

            for(int j = 1; j <= n; j++)

                if(Map[i][j] < Map[i][k] * Map[k][j])

                    Map[i][j] = Map[i][k] * Map[k][j];

}

 

int main()

{

    int i, j, cas = 0;

    double rate;

    char s[100], s1[100], s2[100];

    while(~scanf("%d",&n) && n)

    {

        Init();

        map<string, int> mp;

        for(i = 1; i <= n; i++)

        {

            scanf("%s",s);

            mp[s] = i;

        }

        scanf("%d",&m);

        for(i = 0; i < m; i++)

        {

            scanf("%s%lf%s",s1, &rate, &s2);

            int u = mp[s1], v = mp[s2];

            Map[u][v] = rate;

        }

        Floyd();

        bool flag = false;

        for(i = 1; i <= n; i++)

            if(Map[i][i] > 1)

            {

                flag = true;

                break;

            }

        printf("Case %d: ",++cas);

        printf("%s\n",flag ? "Yes" : "No");

    }

    return 0;

}


Bellman-Ford算法:


#include<stdio.h>

#include<string.h>

#include<map>

#include<string>

#include<iostream>

using namespace std;

int n, m, c;

double dis[35];

struct edge

{

    int a, b;

    double rate;

}e[1000];

 

bool Bellman_Ford(int start)

{

    for(int i = 1; i <= n; i++)

        dis[i] = 0;

    dis[start] = 1;

    for(int k = 0; k < n; k++)

        for(int i = 0; i < c; i++)

        {

            if(dis[e[i].b] < dis[e[i].a] * e[i].rate)

                dis[e[i].b] = dis[e[i].a] * e[i].rate;

        }

    for(int i = 0; i < c; i++)

        if(dis[e[i].b] < dis[e[i].a] * e[i].rate)

            return true;

    return false;

}

 

int main()

{

    int i, j, cas = 0;

    char s[100], s1[100], s2[100];

    double rate;

    while(~scanf("%d",&n) && n)

    {

        c = 0;

        map<string, int> mp;

        for(i = 1; i <= n; i++)

        {

            scanf("%s",s);

            mp[s] = i;

        }

        scanf("%d",&m);

        for(i = 0; i < m; i++)

        {

            scanf("%s%lf%s",s1, &rate, s2);

            int u = mp[s1], v = mp[s2];

            e[c].a = u;

            e[c].b = v;

            e[c++].rate = rate;

        }

        bool flag = Bellman_Ford(1);

        printf("Case %d: ",++cas);

        if(flag)

            printf("Yes\n");

        else

            printf("No\n");

    }

    return 0;

}

猜你喜欢

转载自blog.csdn.net/w13884794538/article/details/81486562