PAT1012. The Best Rank (25)

1012. The Best Rank (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algebra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (<=2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output "N/A".

Sample Input
5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999
Sample Output
1 C
1 M
1 E
1 A
3 A
N/A


对结构体进行排序


#include <iostream>
#include <algorithm>
#include <string>

using namespace std;

struct person
{
    string id;
    int grade[5];
    int grank[5];
};

const string sub[4]={"A", "C", "M", "E"};

int flag = -1;


bool cmp(person p1, person p2)
{
    return p1.grade[flag] > p2.grade[flag];
}

int main()
{
    ios::sync_with_stdio(false);
    int n, m;
    while(cin>>n>>m)
    {
        person p[2005];
        for(int i=0;i<n;++i)
        {
            cin>>p[i].id;
            for(int j=1;j<4;++j)
                cin>>p[i].grade[j];
            p[i].grade[0] = (p[i].grade[1] + p[i].grade[2] + p[i].grade[3])/3.0 +0.5;
        }
        /*
        for(int i=0;i<n;++i)
            cout<<p[i].id<<" "<<p[i].grade[0]<<endl;
            */
        for(flag = 0; flag < 4; ++flag)
        {
            sort(p, p+n, cmp);
            for(int i=0;i<n;++i)
            {
                p[i].grank[flag] = i+1;
                if(p[i].grade[flag] == p[i-1].grade[flag])
                    p[i].grank[flag] = p[i-1].grank[flag];
            }
        }
        /*
        for(int i=0;i<n;++i)
            cout<<p[i].id<<" "<<p[i].grank[0]<<" "<<p[i].grank[1]<<" "<<p[i].grank[2]<<" "<<p[i].grank[3]<<endl;*/
        while(m--)
        {
            bool f=false;
            int ss, tt;
            string name;
            cin>>name;
            for(int i=0;i<n;++i)
            {
                if(name==p[i].id)
                {
                    f = true;
                    ss = n, tt = n;
                    for(int j=0;j<4;++j)
                        if(ss > p[i].grank[j])
                        {
                            ss = p[i].grank[j];
                            tt = j;
                        }
                    break;
                }
            }
            if(f)
                cout<<ss<<" "<<sub[tt]<<endl;
            else
                cout<<"N/A"<<endl;
        }
    }
    return 0;
}




猜你喜欢

转载自blog.csdn.net/acsuccess/article/details/78711428