H - Bone Collector

H - Bone Collector

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …

https://vj.z180.cn/0bf307b7a4c44236bd26a289041b24d5?v=1577504451

The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
Input The first line contain a integer T , the number of cases. Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone. Output One integer per line representing the maximum of the total value (this number will be less than 2 31).

Sample Input

1
5 10
1 2 3 4 5
5 4 3 2 1
Sample Output
14

思路如下:

这题是一个标准的01背包问题,我们需要理解01背包的状态转移方程。

题解如下

#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;

const int Len = 1005;
int dp[Len];
int v[Len],w[Len];	//v物品所占的空间,w品的价值

int main()
{
    int t;
    cin>>t;		
    while(t --)
    {
        int n,m;
        cin>>n>>m;
        for(int i = 0;i < n;i ++)
            cin>>w[i];
        for(int i = 0;i < n;i ++)
            cin>>v[i];
        memset(dp,0,sizeof(dp));
        for(int i = 0;i < n;i ++)
            for(int j = m;j >= v[i];j --)
                dp[j] = max(dp[j],dp[j - v[i]] + w[i]);
                
        cout<<dp[m]<<endl;
    }
    return 0;
}
发布了73 篇原创文章 · 获赞 100 · 访问量 2704

猜你喜欢

转载自blog.csdn.net/qq_34261446/article/details/103742882