I - Bone Collector

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

 

Input

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output

One integer per line representing the maximum of the total value (this number will be less than 2 31).

Sample Input

1

5 10

1 2 3 4 5

5 4 3 2 1

Sample Output

14

  • 题意概括  :

骨收集者,喜欢收集各种骨头,他有一个体积很大的v形大袋子,每种骨头有不同的体积和价值,现在给你袋子的容量以及骨头的体积和价值,问能收集到的骨头的最大价值。

  • 解题思路  :

创建一个一维的dp数组,j控制体积,i控制骨头的类别,w【i】表示每种骨头的价值,v【i】表示骨头的体积。状态转移方程:dp[j] = max(dp[j],dp[j-v[i]] + w[i]);

#include<stdio.h>
#include<string.h>
#include<algorithm>

using namespace std;

int dp[1005],v[1010],w[1010];
int n,m;

int DP()
{
	int i,j,k;
	memset(dp,0,sizeof(dp));
	for(i = 0;i<=n;i ++)
	{
		 for(j = m;j>=v[i];j --)
		 {
		 	dp[j] = max(dp[j],dp[j-v[i]] + w[i]);
		 }
	}
	printf("%d\n",dp[m]);
}
int main()
{
	int T,i,j,k;
	
	scanf("%d",&T);
	while(T --)
	{
		scanf("%d %d",&n,&m);
		for(i = 1;i<=n;i ++)
		{
			scanf("%d",&w[i]);
		}
		for(i = 1;i<=n;i ++)
		{
			scanf("%d",&v[i]);
		}
		DP();
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/y1356998843/article/details/81413916