I - Bone Collector HDU - 2602 Bone Collector 01背包

I - Bone Collector HDU - 2602 

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave … 
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ? 

Input

The first line contain a integer T , the number of cases. 
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output

One integer per line representing the maximum of the total value (this number will be less than 2 31).

Sample Input

1
5 10
1 2 3 4 5
5 4 3 2 1

Sample Output

14

题意:体积为V的袋子最多能装多大价值的骨头;输入:T个样例,N个骨头,袋子体积V,N个整数:骨头的价值,N个整数:骨头的体积

直接套01背包 

#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <queue>
#include <map>
#include <set>
#include <stack>
#define fora(i,a,b) for(i=a;i<b;i++)
#define fors(i,a,b) for(i=a;i>b;i--)
#define fora2(i,a,b) for(i=a;i<=b;i++)
#define fors2(i,a,b) for(i=a;i>=b;i--)
#define PI acos(-1.0)
#define eps 1e-6
#define INF 0x3f3f3f3f

typedef long long LL;
typedef long long LD;
using namespace std;
const int maxn=1000+11;
const int mod=10056;
int N,V;
struct node
{
    int var,w;
}a[maxn];
int dp[maxn];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&N,&V);
        for(int i=1;i<=N;i++)
        {
            scanf("%d",&a[i].var);
        }
        for(int i=1;i<=N;i++)
        {
            scanf("%d",&a[i].w);
        }
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=N;i++)
        {
            for(int j=V;j>=a[i].w;j--)
            {
                dp[j]=max(dp[j],dp[j-a[i].w]+a[i].var);
            }
        }
        printf("%d\n",dp[V]);



    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/liyang__abc/article/details/81384858