Bone Collector (dp)

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

Input

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output

One integer per line representing the maximum of the total value (this number will be less than 2 31).

Sample Input

1
5 10
1 2 3 4 5
5 4 3 2 1

Sample Output

14

题意:

第一行输入测试数据的组数。 第二行输入骨头的个数和自己背包的体积。  第三行输入每个骨头的价值。  第四行输入每个骨头的体积。  输出可以获得的最大价值。
此题为背包问题中的一种,一个物品只能拿一次,求最大获得价值。

#include<stdio.h>
#include<string.h>
#define max(a,b) (a>b?a:b)

int main()
{
    int i,j,t,n,m,a[1001],b[1001],dp[1001];
    scanf("%d",&t);
    while(t --)
    {
        scanf("%d%d",&n,&m);
        memset(dp,0,sizeof(dp));
        for(i = 1; i <= n; i ++)
            scanf("%d",&a[i]);
        for(i = 1; i <= n; i ++)
            scanf("%d",&b[i]);
        for(i = 1; i <= n; i ++)
            for(j = m; j >= b[i]; j --)
            	dp[j] = max(dp[j],dp[j-b[i]]+a[i]);
    
        printf("%d\n",dp[m]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/queen00000/article/details/81331826