Bone Collector

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave … 
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ? 

InputThe first line contain a integer T , the number of cases. 
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone. OutputOne integer per line representing the maximum of the total value (this number will be less than 2  31). Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1
Sample Output
14
#include<stdio.h>
#include<string.h>
int dp[1010][1010];
int max(int x,int y)
{
    return x>y?x:y;
}

int main()
{
    int t,n,c,i,j;
    int w[1000],v[1000];
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&c);
        for(i=1;i<=n;i++)
        scanf("%d",&w[i]);
        for(i=1;i<=n;i++)
        scanf("%d",&v[i]);
        memset(dp,0,sizeof(dp));
         for(i=1;i<=n;i++)
        {
            for(j=0;j<=c;j++)
            {
                if(v[i]<=j)//表示第i个物品将放入大小为j的背包中
                    dp[i][j]=max(dp[i-1][j],dp[i-1][j-v[i]]+w[i]);//第i个物品放入后,那么前i-1个物品可能会放入也可能因为剩余空间不够无法放入
                else //第i个物品无法放入
                    dp[i][j]=dp[i-1][j];
            }
        }
        printf("%d\n",dp[n][c]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/guoshuyan12/article/details/74971302