【HDU 2602】【Bone Collector】

题目:

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave … 
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ? 

Input

The first line contain a integer T , the number of cases. 
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output

One integer per line representing the maximum of the total value (this number will be less than 2 31).

Sample Input

1
5 10
1 2 3 4 5
5 4 3 2 1

Sample Output

14

解题思路:裸的01背包,直接输入数据后,求解就可以。

ac代码:

#include<cstdio> 
#include<cstring>
#include<algorithm>
#include<iostream>
#define maxn 1005
using namespace std;

int val[maxn];
int vum[maxn];
int dp[maxn];
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int n,v;
		scanf("%d%d",&n,&v);
		for(int i=0;i<n;i++)
			scanf("%d",&val[i]);
		for(int i=0;i<n;i++)
			scanf("%d",&vum[i]);
		memset(dp,0,sizeof(dp));
		for(int i=0;i<n;i++)
		{
			for(int j=v;j>=vum[i];j--)
			{
				dp[j]=max(dp[j],dp[j-vum[i]]+val[i]);	
			}	
		} 
		printf("%d\n",dp[v]);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_42505741/article/details/81669136