hdu2955 Robberies (01背包)

Problem Description

The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.

For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.

His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.

Input

The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .

Output

For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints

0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

Sample Input

3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05

Sample Output

2
4
6

思路:

把被抓概率p转化为逃跑概率1-p
d[i]表示抢i块钱的最大逃跑概率
物品的权值是概率,物品的容量是钱数
然后就是普通的01背包
注意概率是乘法计算不是加法计算

算完之后从大到小遍历,找到第一个可行的答案就break

code:

#include<bits/stdc++.h>
using namespace std;
//#define int long long
const int maxm=1e4+5;//因为最多100个物品,每个物品最多100块钱,所以要开1e4
double d[maxm];//d[i]为恰好偷i块钱,逃跑的最大概率
int v[maxm];
double p[maxm];
signed main(){
    int T;
    scanf("%d",&T);
    while(T--){
        double q;
        int n;
        scanf("%lf%d",&q,&n);
        int c=0;
        for(int i=1;i<=n;i++){//
            scanf("%d%lf",&v[i],&p[i]);
            p[i]=1-p[i];//把被抓的概率改成逃跑的概率
            c+=v[i];
        }
        for(int i=1;i<=c;i++)d[i]=0;
        d[0]=1;//偷0个物品的逃跑概率为1
        for(int i=1;i<=n;i++){
            for(int j=c;j>=v[i];j--){
                d[j]=max(d[j],d[j-v[i]]*p[i]);
            }
        }
        int ans=0;
        for(int i=c;i>=0;i--){
            if(d[i]>=1-q){
                ans=i;
                break;
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}
发布了364 篇原创文章 · 获赞 26 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/weixin_44178736/article/details/103438847
今日推荐