HDU2955 Robberies【01背包】

Robberies

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 32227    Accepted Submission(s): 11698


 

Problem Description

The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.


For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.


His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.

 Input

The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj . 
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .

Output

For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

Sample Input

3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05

Sample Output

2
4
6

Source

IDI Open 2009

问题链接:HDU2955 Robberies

问题描述:抢银行,有N个银行,每个银行有两个值,拥有的钱数和抢劫此银行被抓的概率。在被抓概率小于P时,求能抢到的最多钱数。注意被抓概率不是简单求和,而是P=1-(1-p1)*(1-p2)*(1-p3),p1,p2,p3是抢劫各个银行被抓的概率

解题思路:01背包问题。使用各个银行的总钱数作为背包容量,概率为价值,dp[v]存储抢劫钱数v的最大安全概率。问题转化为安全概率大于等于1-P时的最大容量

AC的C++代码:

#include<iostream>
#include<algorithm>
#include<cstring>

using namespace std;

const int N=105;

struct Bank{
	int v;//钱数 
	double p;//被抓概率 
}a[N];

double dp[10100];

int main()
{
	int t,n;
	double P;
	scanf("%d",&t);
	while(t--){
		memset(dp,0,sizeof(dp));
		int sum=0;
		scanf("%lf%d",&P,&n);
		for(int i=0;i<n;i++){
			scanf("%d%lf",&a[i].v,&a[i].p);
			sum+=a[i].v;
		}
		dp[0]=1;//不偷的安全概率为1 
		for(int i=0;i<n;i++)
		  for(int j=sum;j>=a[i].v;j--)
		    dp[j]=max(dp[j],dp[j-a[i].v]*(1-a[i].p));
		for(int i=sum;i>=0;i--)
		  if(dp[i]>=1-P){
		  	printf("%d\n",i);
		  	break;
		  }
	}
	return 0;
 } 

猜你喜欢

转载自blog.csdn.net/SongBai1997/article/details/83744157
今日推荐