2019_GDUT_新生专题 图论 A - Cow Contest

题目

N (1 ≤ N ≤ 100) cows, conveniently numbered 1…N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ N; A ≠ B), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

  • Line 1: Two space-separated integers: N and M
  • Lines 2…M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

  • Line 1: A single integer representing the number of cows whose ranks can be determined

Sample Input
5 5
4 3
4 2
3 2
1 2
2 5
Sample Output
2

将牛视为一个个点,如果i牛能打败j牛,就有一条由i到j的长度为1的单向路,j到i有一条长度为-1的单向路,这样转换为点是否连通的问题。如果某头牛连通其他所有的牛,那么这头牛的的等级就是可以确定的。一百头牛,可以用floyd。跑Floyd的时候不是比较大小,而是看选的两条路是不是都是1或者都是-1,代表i牛>k牛>j牛或者i牛<k牛<j牛。

代码:

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#define INF 0x3f3f3f3f
using namespace std;
int n,m,a[1000][1000];

int main()
{
	int A,B;
	cin>>n>>m;
	memset(a,INF,sizeof(a));
	for (int i=1;i<=m;i++)
	{
		cin>>A>>B;
		a[A][B]=1;
		a[B][A]=-1;
	}
	for (int k=1;k<=n;k++)
		for (int i=1;i<=n;i++)
			for (int j=1;j<=n;j++)
				if (a[i][k]==a[k][j] && a[i][k]!=INF)
				a[i][j]=a[i][k];
	int ans=0,sum=0;
	for (int i=1;i<=n;i++)
	{
		sum=0;
		for (int j=1;j<=n;j++)
		{
			if (a[i][j]!=INF)
			sum++;
		}
		if (sum==n-1)
		ans++;
	}
	cout<<ans;
	return 0;
}
发布了14 篇原创文章 · 获赞 0 · 访问量 294

猜你喜欢

转载自blog.csdn.net/qq_39581539/article/details/104011510
今日推荐