1012 The Best Rank (25 分)(排序,排名类模拟)

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of CME and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of CM and E. Then there are Mlines, each containing a student ID.

Output Specification:

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:

1 C
1 M
1 E
1 A
3 A
N/A
#include<bits/stdc++.h>
#pragma GCC optimize(3)
#define max(a,b) a>b?a:b
using namespace std;
typedef long long ll;
map<int,int>mp;
struct node{
    int id,C,M,E,A;
}p[2005];
struct ans{
    int rank;
    char c;
}q[2005];
bool cmp1(node a,node b){
    return a.A>b.A;
}
bool cmp2(node a,node b){
    return a.C>b.C;
}
bool cmp3(node a,node b){
    return a.M>b.M;
}
bool cmp4(node a,node b){
    return a.E>b.E;
}
int main(){
    int n,m;
    cin>>n>>m;
    for(int i=1;i<=n;i++){
    	cin>>p[i].id>>p[i].C>>p[i].M>>p[i].E;
    	p[i].A=(p[i].C+p[i].M+p[i].E)/3;
    	mp[p[i].id]=i;
    	q[i].rank=10086;
    }
    sort(p+1,p+1+n,cmp1);
    int last=10086,rank=0;
    for(int i=1;i<=n;i++){
    	if(p[i].A!=last){
    	   last=p[i].A;
    	   rank=i;
	}
    	int pos=mp[p[i].id];
    	if(rank<q[pos].rank) q[pos].rank=rank,q[pos].c='A';
    }
    sort(p+1,p+1+n,cmp2);
    last=10086,rank=0;
    for(int i=1;i<=n;i++){
    	if(p[i].C!=last){
    	   last=p[i].C;
    	   rank=i;
	}
    	int pos=mp[p[i].id];
    	if(rank<q[pos].rank) q[pos].rank=rank,q[pos].c='C';
    }
    sort(p+1,p+1+n,cmp3);
    last=10086,rank=0;
    for(int i=1;i<=n;i++){
    	if(p[i].M!=last){
    	   last=p[i].M;
    	   rank=i;
        }
        int pos=mp[p[i].id];
    	if(rank<q[pos].rank) q[pos].rank=rank,q[pos].c='M';
    }
    sort(p+1,p+1+n,cmp4);
    last=10086,rank=0;
    for(int i=1;i<=n;i++){
    	if(p[i].E!=last){
    	   last=p[i].E;
    	   rank=i;
	}
    	int pos=mp[p[i].id];
    	if(rank<q[pos].rank) q[pos].rank=rank,q[pos].c='E';
     }
     while(m--){
	int id;
	cin>>id;
	if(mp.find(id)==mp.end()) cout<<"N/A"<<endl;
	else {
	     int pos=mp[id];
	     cout<<q[pos].rank<<" "<<q[pos].c<<endl;
	}
     }
     return 0;
}



发布了415 篇原创文章 · 获赞 47 · 访问量 4万+

猜你喜欢

转载自blog.csdn.net/qq_42936517/article/details/101999471
今日推荐