Milking Time poj——3616(dp)

Milking Time
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 17585 Accepted: 7546
Description

Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0…N-1) so that she produces as much milk as possible.

Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houri ≤ N), an ending hour (starting_houri < ending_houri ≤ N), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.

Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.

Input

  • Line 1: Three space-separated integers: N, M, and R
  • Lines 2…M+1: Line i+1 describes FJ’s ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi

Output

  • Line 1: The maximum number of gallons of milk that Bessie can product in the N hours

Sample Input

12 4 2
1 2 8
10 12 19
3 6 24
7 10 31
Sample Output

43

题意

m个任务,已知开始结束时间(小于n),这段时间能产生的数量。执行某任务必须从头至尾,且执行完一个任务需休息r时间间隔。问n时间内能产生的最大数量和。

解释

先对任务按开始时间排序,dp[i].v代表从时间0到执行完第i任务的时间间隔内的的最大数量。
转移方程为
dp[i].v = max(dp[i].v, dp[j].v + dp[j].eff); j 属于0~i-1
注意dp[i].v的初值为dp[i].eff。
ans取dp[ ].v最大值

#include <cstdio>
#include <algorithm>
int const maxn = 1e3 + 2;
using namespace std;
struct node{
	int start, end;
	int eff;
	int v;
}dp[maxn];
int cmp(node a, node b){
	return a.start < b.start;
}
int main(){
	int n, m, r, i, j, ans = 0;
	scanf("%d %d %d", &n, &m, &r);
	for (i = 0; i < m; i++)
		scanf("%d %d %d", &dp[i].start, &dp[i].end, &dp[i].eff);
	sort(dp, dp + m, cmp);
	for (i = 0; i < m; i++){
		dp[i].v = dp[i].eff;
		for (j = 0; j < i; j++){
			if(dp[j].end + r <= dp[i].start)
			dp[i].v = max(dp[i].v, dp[j].v+ dp[i].eff);
		}
		ans = max(ans, dp[i].v);
	}
	printf("%d", ans); 
	return 0;
}
发布了52 篇原创文章 · 获赞 2 · 访问量 874

猜你喜欢

转载自blog.csdn.net/qq_44714572/article/details/103000154