Milking Time POJ - 3616(动态规划DP)

Milking Time

POJ - 3616

Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0..N-1) so that she produces as much milk as possible.

Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houriN), an ending hour (starting_houri < ending_houriN), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.

Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ RN) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.

Input

* Line 1: Three space-separated integers: N, M, and R
* Lines 2..M+1: Line i+1 describes FJ's ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi

Output

* Line 1: The maximum number of gallons of milk that Bessie can product in the N hours

Sample Input
12 4 2
1 2 8
10 12 19
3 6 24
7 10 31
Sample Output
43
 因为题目的给定数据最晚结束时间一定是小于等于N的,所以我们按照结束时间从小到大排个序,然后从前往后枚举每次选中一个,这个时间段挤不挤奶,判断方法就是枚举之前的时间段,看之前时间段的结束时间点+休息时间r如果小于等于当前枚举的段的开始时间,那就就可以算上这部分价值,比较取最大值
if(milk[i].s >= milk[j].e+r) dp[i] = max(dp[i],dp[j]+milk[i].v)


code:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;
struct node{
    int s,e,v;
    bool operator < (const node &other)const{
        return e < other.e;
    }
}milk[1006];
int dp[1006];
int n,m,r;
int main(){
    cin >> n >> m >> r;
    for(int i = 1; i <= m; i++){
       cin >> milk[i].s >> milk[i].e >> milk[i].v;
    }
    milk[0].e = -r;
    milk[0].v = 0;
    sort(milk+1,milk+1+m);
    memset(dp,0,sizeof(dp));
    int maxv = 0;
    for(int i = 1; i <= m; i++){
        for(int j = 0; j < i; j++){
            if(milk[i].s >= milk[j].e + r){
                dp[i] = max(dp[i],dp[j]+milk[i].v);
            }
            maxv = max(maxv,dp[i]);
        }
    }
    cout << maxv << endl;
    return 0;
}


猜你喜欢

转载自blog.csdn.net/codeswarrior/article/details/80414333