R - Milking Time POJ - 3616

Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0..N-1) so that she produces as much milk as possible.

Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houriN), an ending hour (starting_houri < ending_houriN), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.

Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ RN) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.

Input

* Line 1: Three space-separated integers: N, M, and R
* Lines 2..M+1: Line i+1 describes FJ's ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi

Output

* Line 1: The maximum number of gallons of milk that Bessie can product in the N hours

Sample Input

12 4 2
1 2 8
10 12 19
3 6 24
7 10 31

Sample Output

43

题意:在接下来的N个时间内要给奶牛挤奶,每个奶牛有开始挤奶时间,结束挤奶时间和在挤奶时间内的奶量,每挤完一次奶要休息R个时间,问最多可以挤多少牛奶。

题解:根据开始时间排序后dp,与最长上升子序列相似。dp[i] = dp[i] = max(dp[i],dp[j] + g[i].v)

#include <stdio.h>
#include <algorithm>
#include <iostream>
#include <cstring>
using namespace std;
const int maxn = 1000100;
int n,m,r,dp[maxn];

struct node
{
    int s;//开始
    int e;//结束
    int v;//值
}g[1010];

int cmp(struct node a,struct node b)
{
    if(a.s == b.s)
        return a.v < b.v;
    else
        return a.s < b.s;
}

int main()
{
    scanf("%d %d %d",&n,&m,&r);
    for(int i = 1;i <= m;i++)
    {
        scanf("%d %d %d",&g[i].s,&g[i].e,&g[i].v);
        g[i].e += r;//加上休息时间
    }

    sort(g + 1,g + 1 + m,cmp);
    for(int i = 1;i <= m;i++)
    {
        dp[i] = g[i].v;
        for(int j = 1;j < i;j++)
        {
            if(g[i].s >= g[j].e)//注意是大于等于
            {
                dp[i] = max(dp[i],dp[j] + g[i].v);
            }
        }
    }

    int ans = 0;
    for(int i = 1;i <= m;i++)
    {
        ans = max(ans,dp[i]);
    }

    printf("%d\n",ans);

    return 0;
}

猜你喜欢

转载自blog.csdn.net/Eric_chen_song_lin/article/details/82563818