POJ 3616 Milking Time

Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0..N-1) so that she produces as much milk as possible.

Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houri ≤ N), an ending hour (starting_houri < ending_houri ≤ N), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.

Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.

Input

* Line 1: Three space-separated integers: NM, and R
* Lines 2..M+1: Line i+1 describes FJ's ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi

Output

* Line 1: The maximum number of gallons of milk that Bessie can product in the Nhours

Sample Input
12 4 2
1 2 8
10 12 19
3 6 24
7 10 31
Sample Output

43

PS:一个最长子序列和得问题,由题得,可将开始产奶时间由小到大排序,然后再找产奶量最多得产奶变量的和最大的子序列和。


#include <iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<string>
#include<map>
const int maxn= 1e3+5;
const int mod=1e9;
#define me(a) memset(a,0,sizeof(a))
#define ll long long
using namespace std;
struct node
{
    int l,r,w;
    bool friend operator<(node a,node b)
    {
    	return a.l<b.l;
    }
};
int main()
{
	node a[maxn];
    int t,m,r;
    scanf("%d%d%d",&t,&m,&r);
    for(int i=0;i<m;i++)
    {
    	scanf("%d%d%d",&a[i].l,&a[i].r,&a[i].w);
    		a[i].r+=r;
    }	
    sort(a,a+m);
    int dp[maxn];me(dp);
    int maxn=0;
	for(int i=0;i<m;i++)
	{
		int ma=0;
		for(int j=0;j<i;j++)
			if(a[i].l>=a[j].r)
				ma=max(ma,dp[j]);
		dp[i]=ma+a[i].w;
		maxn=max(maxn,dp[i]);
	}
	cout<<maxn<<endl;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41292370/article/details/80994118