poj 3616 Milking Time 基础dp

Description

Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0..N-1) so that she produces as much milk as possible.

Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houri ≤ N), an ending hour (starting_houri < ending_houri ≤ N), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.

Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.

Input

* Line 1: Three space-separated integers: NM, and R
* Lines 2..M+1: Line i+1 describes FJ's ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi

Output

* Line 1: The maximum number of gallons of milk that Bessie can product in the N hours

Sample Input

12 4 2
1 2 8
10 12 19
3 6 24
7 10 31

Sample Output

43

Source

扫描二维码关注公众号,回复: 3489029 查看本文章

USACO 2007 November Silver

先进行排序,再dp

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int n,m,r;
struct cow
{
    int x,y,w;
}c[1010];
bool cmp(cow a,cow b)
{
    return a.x<b.x;
}
int dp[2000];
int main()
{
    while(~scanf("%d%d%d",&n,&m,&r))
    {int ans=0;
        for(int i=1;i<=m;i++)
        scanf("%d%d%d",&c[i].x,&c[i].y,&c[i].w);
        sort(c+1,c+m+1,cmp);
        for(int i=1;i<=m;i++)
        dp[i]=c[i].w;
        for(int i=1;i<=m;i++)
        {
            for(int j=1;j<i;j++)
            if(c[i].x>=c[j].y+r)
            dp[i]=max(dp[i],dp[j]+c[i].w);
            ans=max(ans,dp[i]);
        }
        printf("%d\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sdauguanweihong/article/details/82929295