POJ - 3616 Milking Time 简单dp 类似HDU - 1069

Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0..N-1) so that she produces as much milk as possible.

Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤starting_houri ≤ N), an ending hour (starting_houri < ending_houri ≤ N), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.

Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.

Input

* Line 1: Three space-separated integers: NM, and R
* Lines 2..M+1: Line i+1 describes FJ's ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi

Output

* Line 1: The maximum number of gallons of milk that Bessie can product in the Nhours

Sample Input
12 4 2
1 2 8
10 12 19
3 6 24
7 10 31
Sample Output
43

思路:当我们要知道到第i头牛最大效率时,我们可以在前i-1头牛中找出满足第i头牛加入进去的最大效率,这样到第i头牛为最后一头牛的最大效率就求出来了,要保证在前i-1头牛中找出的是最大效率我们要先排序,还有就是要隔r时间才可以挤下一头牛,在每头牛的末时间+r就可以了;

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<queue>
#include<cstring>
#include<map>
#include<set>
#include<vector>
using namespace std;
#define ll long long
typedef pair<int,int>P;
typedef vector<int>V;
const int len=1e3+5;
struct Node{
    int s,e,w;
}arr[len];
int dp[len];
bool cmp(Node a,Node b)
{
    if(a.s==b.s)return a.e<b.e;
    return a.s<b.s;
}
int main()
{
    int n,m,r;
    cin>>n>>m>>r;
    n+=r;
    for(int i=1;i<=m;++i)
    {
        scanf("%d%d%d",&arr[i].s,&arr[i].e,&arr[i].w);
        arr[i].e+=r;
    }
    sort(arr+1,arr+m+1,cmp);
    int maxm=0;
    for(int i=1;i<=m;++i)
    {
        dp[i]=arr[i].w;
        for(int j=1;j<i;++j)
        {
            if(arr[i].s>=arr[j].e)
                dp[i]=max(dp[i],dp[j]+arr[i].w);
        }
        maxm=max(maxm,dp[i]);//效率最大的那一组不一定是以第m条牛结尾的;
    }
    cout<<maxm<<endl;
}


猜你喜欢

转载自blog.csdn.net/hutwuguangrong/article/details/80601426