Milking Time - poj3616 - dp

Milking Time

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 13538   Accepted: 5722

Description

Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0..N-1) so that she produces as much milk as possible.

Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houri ≤ N), an ending hour (starting_houri < ending_houri ≤ N), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.

Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.

Input

* Line 1: Three space-separated integers: NM, and R
* Lines 2..M+1: Line i+1 describes FJ's ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi

Output

* Line 1: The maximum number of gallons of milk that Bessie can product in the N hours

Sample Input

12 4 2
1 2 8
10 12 19
3 6 24
7 10 31

Sample Output

43

Source

USACO 2007 November Silver

思路:

先按开始时间排序,开始时间相同,再按结束时间排序

dp[i]:=选到第i个时间段时,最大的挤奶量

从第1到第i-1个时间段,若满足:结束时间加上时间r<=第i段的开始时间,则

dp[i]=max(dp[i],dp[j]+第i次挤奶的量)

最后的结果ans=max(ans,dp[i]);因为最后一次挤奶的时间段不确定

(dp真的好难啊,我怎么都想不出来递推方程,嘤嘤嘤qwq)

代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<cmath>
#include<queue> 
#include<vector>

using namespace std;
struct A{
	int x,y,v;
}qq[1005];

bool cmp(A a,A b){
	if(a.x==b.x){
		return a.y<b.y;
	}
	return a.x<b.x;
}
int dp[1005];

int main(){
	int n,m,r;
	scanf("%d%d%d",&n,&m,&r);
	for(int i=0;i<m;i++){
		scanf("%d%d%d",&qq[i].x,&qq[i].y,&qq[i].v);
	}
	sort(qq,qq+m,cmp);
	int ans=0;

	for(int i=0;i<m;i++){
		dp[i]=qq[i].v;
		for(int j=0;j<i;j++){
			if(qq[j].y+r<=qq[i].x){
				dp[i]=max(dp[i],dp[j]+qq[i].v);
			}
		}
		ans=max(ans,dp[i]);
	}
    printf("%d\n",ans);
}

猜你喜欢

转载自blog.csdn.net/m0_37579232/article/details/81330134