The Suspects POJ - 1611 并查集

一、内容

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects. 

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed. 

Output

For each case, output the number of suspects in one line. 

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

二、思路

  • 我们用rec来记录每一组的成员。 由于所有一组的成员是连通的,那么我们只需要所有人和第一个连通即可(所有人的上级都是第一个成员)。 若这一组的成员中有人的上级是0, 那么我们就让第一个元素的上级变成0, 0自己的上级也变成0(因为若0在这组中,可能修改了0的上级为第一个成员)
  • 最后我们只需要求i点的上级是否是0,若是0即是怀疑对象。

三、代码

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
const int N = 30005;
int n, m, k, p[N], rec[N]; // rec记录一组的成员 
int find(int x) {
	return x == p[x] ? x : (p[x] = find(p[x]));
}
void init() {
	for (int i = 0; i < n; i++) p[i] = i;
}
int main() {
	while (scanf("%d%d", &n, &m), n) {
		init();
		for (int i = 1; i <= m; i++) {
			scanf("%d", &k);
			for (int j = 1; j <= k; j++) scanf("%d", &rec[j]);
			//让所有人的上级都是第一个元素 若组中有0那么让第一个人的上级是0
			int fx = find(rec[1]);
			bool ok = false; //判断0是否在这个组中 
			for (int j = 2; j <= k; j++) {
				int fy = find(rec[j]);
				p[fy] = fx;
				if (fy == 0) ok = true; //若有人的上级是0那么我们还是要将第一个的上级置为0 
			} 
			if (ok) {
				p[fx] = 0; //如果0在 那么所有人的上级变为0 
				p[0] = 0;  //由于上边循环更新了0自己的上级 所以重新置为自己 
			} 
		}
		int ans = 0; //求上级是0的
		for (int i = 0; i < n; i++) {
			if (find(i) == 0) ans++; //若i所在连通块的上级是0 	 
		} 
		printf("%d\n", ans);
	}	
	return 0;
}
发布了343 篇原创文章 · 获赞 244 · 访问量 4万+

猜你喜欢

转载自blog.csdn.net/qq_41280600/article/details/103934460