POJ 1611 并查集模板题 The Suspects

The Suspects

 

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
Once a member in a group is a suspect, all members in the group are suspects. 
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input
The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output
For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
Sample Output
4
1
1


比HDU那题多了一个步骤,要保存被传染的人数,所以多了一个ren[]数组

#include <iostream>
#include <cstdio>
using namespace std;
int n,m;
int pre[30005],ren[30005];
void init()
{
    for(int i=0;i<n;i++)
    {
        pre[i]=i; ren[i]=1;  //初始人人朋友圈只有自己一个人
    }
}
int Find(int x)   //路径压缩
{
    if(x!=pre[x]) pre[x]=Find(pre[x]);  
    return pre[x];
}
void join(int x,int y)
{
    int fx=Find(x);
    int fy=Find(y);
    if(fx!=fy)
    {
        pre[fx]=fy;
        ren[fy]+=ren[fx];  //要是祖先不同,两个朋友圈人数合并
    }
}
int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        if(n==0&&m==0) break;
        init();
        for(int i=1;i<=m;i++)
        {
            int s,s1;
            scanf("%d%d",&s,&s1);
            for(int j=1;j<s;j++)
            {
                int x;scanf("%d",&x);
                join(s1,x);
            }
        }
        printf("%d\n",ren[Find(0)]); //因为0号同学是传染病源,找到他的祖先的朋友圈有几人就是答案
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41037114/article/details/81032866