[POJ1611] The Suspects (并查集)

题目

The Suspects
Time Limit: 1000MS Memory Limit: 20000K
Total Submissions: 48259 Accepted: 23092

Description
Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input
The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output
For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

Source
Asia Kaohsiung 2003

题目大意

分组问题, 列出m个组的队员,0号队员是suspect, 与0号待在一个队的所有成员也是suspect。最后只要与suspect一个队的所有人都是suspect最后求suspect的总数。

思路

典型的并查集思想,把每个队都变成一个集合,同时将队首保存为该集合根同时保存集合中所有成员的总数。在形成每个队的集合的过程中也进行的操作,就是把该成员所在集合与另外包该队员的集合并起来,具体过程参见代码。最后就输出0所在集合成员个数就行喽~

代码

#include <cstdio>

const int maxn = 3e4 + 10;

int pre[maxn];
int v[maxn];
int sum[maxn];
int n, m;

int find(int x)
{
    int t = x;
    while(t != pre[t])
        t = pre[t];
    return t;
}

int join(int x, int y)
{
    int fx = find(x);
    int fy = find(y);
    if (fx != fy) {
        pre[fy] = fx;
        sum[fx] += sum[fy];           // 把集合元素的个数体现在“根”的部位
    }
}

void init()
{
    for(int i = 0; i < n; i++) {
        pre[i] = i;
        sum[i] = 1;
    }
}

int main()
{
    //freopen("input.txt", "r", stdin);
    while(~scanf("%d%d", &n, &m) && n) {
        init();
        while(m--) {
            int N;
            scanf("%d", &N);
            for(int i = 0; i < N; i++) {
                scanf("%d", &v[i]);
            }
            for(int i = 0; i < N - 1; i++) {
                join(v[i], v[i + 1]);
            }
        }
        printf("%d\n", sum[find(0)]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sunmaoxiang/article/details/80779813