POJ - 1611 The Suspects (并查集)

                                        The Suspects

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

题意描述:

N个学生m个组织每个学生可以加入多个组织,当一个组织中有一个人感染病毒这个组织中的所有人都感染了病毒,最初只有0号学生感染,问最后有多少人感染。

解题思路:

将一个组织的人存为一个祖先,最初感染数为一,当有同学和0号同学祖先相同,感染数加一。

#include<stdio.h>
int f[30010];
int getf(int i)
{
	if(f[i]==i)
		return i;
	else
	{
		f[i]=getf(f[i]);
		return f[i];
	}
}
int merge(int u,int v)
{
	int t1,t2;
	t1=getf(u);
	t2=getf(v);
	if(t1!=t2)
	{
		f[t2]=t1;
		return 1;
	}
	return 0;
}
int main()
{
	int n,m,x,a,b,i,j,cut;
	while(scanf("%d%d",&n,&m))
	{
		if(n==0&&m==0)
			break;
		for(i=0;i<n;i++)
			f[i]=i;
		for(i=1;i<=m;i++)
		{
			scanf("%d%d",&x,&a);
			for(j=2;j<=x;j++)
			{
				scanf("%d",&b);
				merge(a,b);
				a=b;
			}
		}
		cut=1;
		for(i=1;i<n;i++)
		{
			if(getf(i)==getf(0))
				cut++;
		}
		printf("%d\n",cut);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/kongsanjin/article/details/81482261