POJ-1611-The Suspects(并查集)

                                                        The Suspects
 

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

题意描述:

给你n个人和m个组织,每个组织里的人都有自己的编号,其中0号是患病的并且与0号直接或者间接在一个组织里的人也患病,求患病的人数,把每个人领导的人数都记录下来,最后把0号的祖先领导的人数输出即为患病人数

程序代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int f[30010],n,m,a[30010],num[30010];
int getf(int u);
void merge(int u,int v);
int main()
{
	int i,j,k,t,sum,count=0,u,v;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		if(n==0&&m==0)
			break;
		for(i=0;i<n;i++)
		{
			f[i]=i;
			num[i]=1;
		}
		while(m--)
		{
			scanf("%d",&t);
			for(i=0;i<t;i++)	
				scanf("%d",&a[i]);	
			for(i=0;i<t-1;i++)
			merge(a[i],a[i+1]);
		}
		count=getf(0);
		printf("%d\n",num[count]);
	}
	return 0;
}
int getf(int u)
{
	if(u==f[u])
		return u;
	f[u]=getf(f[u]);
	return f[u];
}
void merge(int u,int v)
{
	u=getf(u);
	v=getf(v);
	if(u!=v)
	{
		f[v]=u;
		num[u]+=num[v];
	}
	return;
}

猜你喜欢

转载自blog.csdn.net/HeZhiYing_/article/details/81454514