POJ1611:The Suspects(并查集)

The Suspects

Time Limit: 1000MS   Memory Limit: 20000K
Total Submissions: 51587   Accepted: 24675

题目链接http://poj.org/problem?id=1611

Description:

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input:

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output:

For each case, output the number of suspects in one line.

Sample Input:

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output:

4
1
1

题意:

有m组,0为起点,有0的那一组全是嫌疑人,之后会不断传递到其它组去,问一共有多少人是嫌疑人。

题解:

这题我一开始乱搞了一通,先贴个代码。复杂度应该是可以过的。

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <vector>
#include <queue>
using namespace std;

const int N = 30005 ,M = 505;
int n,m;
vector <int > vec[N];
vector <int > g[M];
int vis[N],check[M];

int main(){
    while(scanf("%d%d",&n,&m)){
        if(n==0 && m==0) break;
        queue <int > q;memset(vis,0,sizeof(vis));memset(check,0,sizeof(check));
        for(int i=0;i<=n;i++) vec[i].clear();
        for(int i=0;i<=m;i++) g[i].clear();
        for(int i=1,k;i<=m;i++){
            scanf("%d",&k);
            for(int j=1,num;j<=k;j++){
                scanf("%d",&num);
                vec[num].push_back(i);
                if(!num){
                    if(!check[i]) q.push(i);
                    check[i]=1;
                }
                g[i].push_back(num);
            }
        }
        vis[0]=1;
        while(!q.empty()){
            int now = q.front();q.pop();
            for(int i=0;i<g[now].size();i++){
                int t = g[now][i];
                if(!vis[t]){
                    vis[t]=1;
                    for(int j=0;j<vec[t].size();j++){
                        if(!check[vec[t][j]]){
                            check[vec[t][j]]=1;
                            q.push(vec[t][j]);
                        }
                    }
                }
            }
        }
        int ans = 0;
        for(int i=0;i<=n;i++) if(vis[i]) ans++;
        printf("%d\n",ans);
    }
    return 0;
}
View Code

然后再来说说正解。

由于关系会传递,我们想到了并查集(合并集合),一开始的时候将每一组合并到同一个集合中。如果一个人在不同的组,那么根据并查集,这几个组都会被放入同一个集合中。

最后看看谁的父亲和0的父亲一样就好了。

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;

const int N = 30005 ,M = 505;
int n,m;
int f[N+M];

int find(int x){
    return f[x]==x ? x : f[x]=find(f[x]);
}

void Union(int x,int y){
    int fx=find(x),fy=find(y);
    if(fx==fy) return;
    f[fx]=fy;
}

int main(){
    while(scanf("%d%d",&n,&m)){
        if(!n && !m) break;
        for(int i=0;i<=n+m+1;i++) f[i]=i;
        for(int i=1,k;i<=m;i++){
            scanf("%d",&k);
            for(int j=1,num;j<=k;j++){
                scanf("%d",&num);
                Union(num,n+i);
            }
        }
        int ans = 0,std=find(0);
        for(int i=0;i<=n;i++){
            if(std==find(i)) ans++;
        }
        printf("%d\n",ans);
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/heyuhhh/p/9986203.html