The Suspects POJ - 1611 (简单并查集)

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
Once a member in a group is a suspect, all members in the group are suspects. 
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input
The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output
For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
Sample Output
4
1

1

一道并查集裸题了吧。挺简单的。看懂题意就好了。也没什么可以说的。

#include <stdio.h>
#include <algorithm>
#include <string.h>
#include <iostream>
using namespace std;

const int MAXN=50010;
int n,m;
int f[MAXN];
int a[MAXN];
int find(int x)
{
    if(x==f[x])
    {
    	return x;
	}
	else 
	{
		return f[x]=find(f[x]); 
	} 
}
void merge(int x,int y)
{
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy)
	{
		f[fy]=fx;
	}
	return ;
}
int main()
{
	//freopen("C:/input.txt", "r", stdin);
    while(scanf("%d%d",&n,&m)!=EOF)
    {
    	if(n==0&&m==0)
    	{
    		break;
		}
		int ans=0;
		for(int i=0;i<n;i++)
		{
			f[i]=i;
		}
		for(int i=0;i<m;i++)
		{
			int k;
			scanf("%d",&k);
			scanf("%d",&a[0]);
			for(int j=1;j<k;j++)
			{
				scanf("%d",&a[j]);
				merge(a[0],a[j]);
			}
		}
		for(int i=0;i<n;i++)
		{
			if(find(i)==f[0])
			{
				ans++;
			}
		}
		printf("%d\n",ans);
	}
    return 0;
}

猜你喜欢

转载自blog.csdn.net/evildoer_llc/article/details/80445688