1036 Boys vs Girls (25 point(s)) - C语言 PAT 甲级

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。
本文链接: https://blog.csdn.net/huaxuewan/article/details/101792111

1036 Boys vs Girls (25 point(s))

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student’s name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference grade​F​​−grade​M​​. If one such kind of student is missing, output Absent in the corresponding line, and output NA in the third line instead.

Sample Input 1:

3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95

Sample Output 1:

Mary EE990830
Joe Math990112
6

Sample Input 2:

1
Jean M AA980920 60

Sample Output 2:

Absent
Jean AA980920
NA

题目大意:

输入 N 行,name,gender,ID 和 grade;

输出 F(female) 学生中 grade 的最大值,M(male) 学生中 grade 的最小值,第三行输出两者的差值 gradeF - gradeM;若没有女生或没有男生,对应成绩输出 Absent,第三行输出 NA

设计思路:

用结构体存储男生和女生对应的信息,输出

编译器:C (gcc)
#include <stdio.h>

struct node {
        int grade;
        char name[11];
        char id[11];
};

int main(void)
{
        struct node t = {0}, m = {101}, f = {-1};
        int n;
        char sex;

        scanf("%d", &n);
        while (n > 0) {
                scanf("%s %c %s %d", t.name, &sex, t.id, &t.grade);
                if (sex == 'M') {
                        if (t.grade < m.grade)
                                m = t;
                } else {
                        if (t.grade > f.grade)
                                f = t;
                }
                n--;
        }

        if (f.grade > -1)
                printf("%s %s\n", f.name, f.id);
        else
                printf("Absent\n");
        if (m.grade < 101)
                printf("%s %s\n", m.name, m.id);
        else
                printf("Absent\n");
        if (f.grade > -1 && m.grade < 101)
                printf("%d\n", f.grade - m.grade);
        else
                printf("NA\n");

        return 0;
}

猜你喜欢

转载自blog.csdn.net/huaxuewan/article/details/101792111