1042 Shuffling Machine (20 point(s)) - C语言 PAT 甲级

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。
本文链接: https://blog.csdn.net/huaxuewan/article/details/101866174

1042 Shuffling Machine (20 point(s))

Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid “inside jobs” where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

S1, S2, …, S13,
H1, H2, …, H13,
C1, C2, …, C13,
D1, D2, …, D13,
J1, J2

where “S” stands for “Spade”, “H” for “Heart”, “C” for “Club”, “D” for “Diamond”, and “J” for “Joker”. A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer K (≤ 20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

Sample Input:

2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

Sample Output:

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5

题目大意:

模拟洗牌,输入第一行 K 表示洗牌的次数,第二行表示洗牌顺序,洗牌顺序意思是,当前 1 号位上的牌放到第 36 号位置,当前 2 号位置上的牌放到第 52 号位置,依次类推,一次洗牌完成,再按照洗牌顺序完成下一轮洗牌

设计思路:
  • 洗牌过程中,利用一个中间数组储存上一次结果
  • 54 张牌每 13 张一组,在数组中存储数字,输出时利用除法和取余
编译器:C (gcc)
#include <stdio.h>

int main(void)
{
        int k;
        int sh[54], result[54], temp[54];
        int i, j;

        scanf("%d", &k);
        for (i = 0; i < 54; i++) {
                scanf("%d", &sh[i]);
                sh[i]--;
                result[i] = i;
        }
        for (i = 0; i < k; i++) {
                for (j = 0; j < 54; j++) {
                        temp[j] = result[j];
                }
                for (j = 0; j < 54; j++) {
                        result[sh[j]] = temp[j];
                }
        }

        char *p = "SHCDJ";
        printf("%c%d", p[result[0] / 13], result[0] % 13 + 1);
        for (i = 1; i < 54; i++) {
                printf(" %c%d", p[result[i] / 13], result[i] % 13 + 1);
        }
        return 0;
}

猜你喜欢

转载自blog.csdn.net/huaxuewan/article/details/101866174
今日推荐