PAT 甲级 1041 Be Unique(模拟)

1041 Be Unique (20 分)

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1,10​4​​]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (≤10​5​​) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print None instead.

Sample Input 1:

7 5 31 5 88 67 88 17

Sample Output 1:

31

Sample Input 2:

5 888 666 666 888 888

Sample Output 2:

None

Analysis:

The fisrt person who bets on the number which is unique in the array wins;

c++:

#include<stdio.h>
#include<iostream>
#include<string>
#include<vector>
#include<map>
#include<queue>
#include<set>
#include<math.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
	int n;
	int vis[10001];cin>>n;
	int a[n]; 
	
	for(int i=0;i<n;i++){
		cin>>a[i];
		vis[a[i]]++;
	}
	int j;
	for(j=0;j<n;j++){
		if(vis[a[j]]==1){
			cout<<a[j]<<endl;
			return 0;	
		}
	}
	if(j==n)cout<<"None"<<endl;
	return 0;
}

猜你喜欢

转载自blog.csdn.net/zpjlkjxy/article/details/83686290