1027 Colors in Mars (20 point(s)) - C语言 PAT 甲级

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。
本文链接: https://blog.csdn.net/huaxuewan/article/details/100900434

1027 Colors in Mars (20 point(s))

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input Specification:

Each input file contains one test case which occupies a line containing the three decimal color values.

Output Specification:

For each test case you should output the Mars RGB value in the following format: first output #, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0 to its left.

Sample Input:

15 43 71

Sample Output:

#123456

题目大意:

输入三个十进制的数(0 ~ 168),输出转换为十三进制的数,前面加上一个 # 号

设计思路:

输入 0 ~ 168 的十进制,转换十三进制不会超过两位数

编译器:C (gcc)
#include <stdio.h>

int main(void)
{
	char convert[]= "0123456789ABC";
	int n;
	int i;

	for (i = 0; i < 3; i++) {
		scanf("%d", &n);
		if (i == 0)
			printf("#");
		printf("%c%c", convert[n / 13], convert[n % 13]);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/huaxuewan/article/details/100900434
今日推荐