最短路径变形 POJ 2253

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping. 
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

题目大意:第一个点是起点 ,第二个点是终点其余点是起点和终点之间的点,问从起点到终点最短路上两点之间最远的距离。
这是一个最短路变形问题,dis数组保存的不再是到某一点的最短路径,而是路径上两点之间的最远距离
转移方程dis[i]=min(dis[i],max(ans,arr[pos][i]))
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
using namespace std;
const int N=1e4+7;
const double INF=1e7+7;
int n;
struct stu{
    int a,b;
}p[N];
int mark[N];
double arr[N][N];
double dis[N];
void djstrea(){
    memset(mark,0,sizeof(mark));
    for(int i=1;i<=n;i++){
        dis[i]=arr[1][i];
    }
    dis[1]=0;
    mark[1]=1;
    for(int i=1;i<=n;i++){
        double ans=INF;
        int s;
        for(int i=1;i<=n;i++)
            if(mark[i]==0&&ans>dis[i]){
                ans=dis[i];
                s=i;
            }
        mark[s]=1;
        for(int i=1;i<=n;i++){
            if(mark[i]==0){
                dis[i]=min(dis[i],max(ans,arr[s][i]));//转移方程变啦
            }
        }
    }
}
int main(){
    int k=0;
    int x,y;
    while(scanf("%d",&n)&&n){
        k++;
        for(int i=1;i<=n;i++){
            cin>>x>>y;
            p[i].a=x;
            p[i].b=y; 
        }
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
                arr[i][j]=arr[j][i]=INF;
        
                
        for(int i=1;i<n;i++){
            for(int j=i+1;j<=n;j++){
                arr[j][i]=arr[i][j]=sqrt((p[i].a-p[j].a)*(p[i].a-p[j].a)+(p[i].b-p[j].b)*(p[i].b-p[j].b));
            }
        }
        djstrea();
        printf("Scenario #%d\n",k);
        printf("Frog Distance = %.3f\n",dis[2]);
        cout<<endl;
    }
    return 0;
} 

也可以用flord写:

#include <cstdio>
#include <cstring>
#include <string>
#include <iostream>
#include <stack>
#include <queue>
#include <vector>
#include <cmath>
#include <algorithm>
#define mem(a,b) memset(a,b,sizeof(a))
#define maxnum 300
#define inf 0x3f3f3f3f
using namespace std;
int x[maxnum],y[maxnum],n;
double map[maxnum][maxnum];
void floyd()
{
    for(int k=1; k<=n; k++)
        for(int i=1; i<=n; i++)
            for(int j=1; j<=n; j++)
                map[i][j]=min(map[i][j],max(map[i][k],map[k][j]));//许多通路中最长边中的最小边
//                map[i][j]=min(map[i][j],max(map[i][k],map[k][j]));
}
int main()
{
    int q=1;
    while(~scanf("%d",&n)&&n)
    {
        mem(map,0);
        for(int i=1; i<=n; i++)
            scanf("%d%d",&x[i],&y[i]);
        for(int i=1; i<=n; i++)
            for(int j=i+1; j<=n; j++)
                map[i][j]=map[j][i]=sqrt(double(x[i]-x[j])*(x[i]-x[j])+double(y[i]-y[j])*(y[i]-y[j]));
        floyd();
        printf("Scenario #%d\nFrog Distance = %.3lf\n\n",q++,map[1][2]);
    }
    return 0;

 }


猜你喜欢

转载自www.cnblogs.com/Accepting/p/11324896.html