POJ 2253 Frogger(Floyd Dij Spfa变形)

版权声明:转载请标明出处哦 https://blog.csdn.net/PleasantlY1/article/details/82462509

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone.

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

题目大意:求2点间所有路中最小的最大距离。就是每条路有一个最大2点间距离,求所有路中最小的。

思路:数据小,弗洛伊德,迪杰特斯拉,SPFA都能做,暑假这些忘了不少,拾遗吧。

弗洛伊德:3重循环,暴力求所有点之间的最短路 时间复杂度n^3

迪杰特斯拉:以起点为原点不断扩张找最小,以邻点为媒介找更小缩进。  时间复杂度n^2

SPFA:通过队列进行优化,

Floyd代码:

#include<set>
#include<map>
#include<list>
#include<deque>
#include<cmath>
#include<queue>
#include<stack>
#include<string>
#include<vector>
#include<stdio.h>
#include<sstream>
#include<stdlib.h>
#include<string.h>
//#include<ext/rope>
#include<iostream>
#include<algorithm>
#define pi acos(-1.0)
#define INF 0x3f3f3f3f
#define per(i,a,b) for(int i=a;i<=b;++i)
#define LL long long 
#define swap(a,b) {int t=a;a=b;b=t} 
using namespace std;
//using namespace __gnu_cxx;
int a[300],b[300];
double p[305][305];
int main()
{
	int t,z=0;
	while(scanf("%d",&t)!=EOF&&t!=0)
	{
		z++;
		memset(p,0,sizeof(p));
		per(i,1,t) scanf("%d %d",&a[i],&b[i]);
		per(i,1,t)
		{
			per(j,i+1,t)
			{
				p[j][i]=p[i][j]=sqrt(double(a[i]-a[j])*(a[i]-a[j])+double(b[i]-b[j])*(b[i]-b[j]));
			}
		}
		per(k,1,t)
		{
			per(i,1,t)
			{
				per(j,1,t)
				{
				    p[i][j]=min(p[i][j],max(p[i][k],p[k][j]));
				}
			}
		} 
		printf("Scenario #%d\n",z);
		printf("Frog Distance = %.3lf\n\n",p[1][2]);
	}
	return 0; 
}

Dij代码:

#include<set>
#include<map>
#include<list>
#include<deque>
#include<cmath>
#include<queue>
#include<stack>
#include<string>
#include<vector>
#include<stdio.h>
#include<sstream>
#include<stdlib.h>
#include<string.h>
//#include<ext/rope>
#include<iostream>
#include<algorithm>
#define pi acos(-1.0)
#define INF 0x3f3f3f3f
#define per(i,a,b) for(int i=a;i<=b;++i)
#define LL long long 
#define swap(a,b) {int t=a;a=b;b=t} 
using namespace std;
//using namespace __gnu_cxx;
int n;
struct node{
	int x;
	int y;
}s[300];
double p[300][300];
int vis[300];
double d[300];
void dij(int z)
{
    fill(d,d+300,INF);
    d[z]=0;
    per(i,1,n) 
    {
    	int k,minn=INF;
		per(j,1,n) 
		{
			if(vis[j]==0&&d[j]<minn)//临接点距离最小的 
			{
				k=j;
				minn=d[j];
			}
		}
		vis[k]=1;
		per(j,1,n)// 
		{
			/*if(vis[j]==0&&p[k][j]!=INF&&d[k]+p[k][j]<d[j])//以k为起点,可以到达j且小于j到原点的距离。缩进 
			{
				d[j]=d[k]+p[k][j];
			}*/
			d[j]=min((double)d[j],max((double)d[k],p[k][j]));
		}
	}
}
int main()
{
    int k=1;
    while(~scanf("%d",&n)&&n!=0)
    {
        memset(p,0,sizeof(p));
        memset(vis,0,sizeof(vis)); 
        per(i,1,n) scanf("%d%d",&s[i].x,&s[i].y);
        per(i,1,n)
            per(j,i+1,n)
            {
				p[i][j]=p[j][i]=sqrt(double(s[i].x-s[j].x)*(s[i].x-s[j].x)+double(s[i].y-s[j].y)*(s[i].y-s[j].y));
			}
        dij(1);
        //per(i,1,n) cout<<d[i]<<"*";
        printf("Scenario #%d\nFrog Distance = %.3lf\n\n",k++,d[2]);
    }
    return 0;
}

SPFA:

#include<set>
#include<map>
#include<list>
#include<deque>
#include<cmath>
#include<queue>
#include<stack>
#include<string>
#include<vector>
#include<stdio.h>
#include<sstream>
#include<stdlib.h>
#include<string.h>
//#include<ext/rope>
#include<iostream>
#include<algorithm>
#define pi acos(-1.0)
#define INF 0x3f3f3f3f
#define per(i,a,b) for(int i=a;i<=b;++i)
#define LL long long 
#define swap(a,b) {int t=a;a=b;b=t} 
using namespace std;
//using namespace __gnu_cxx;
int n;
struct node{
	int x;
	int y;
}s[300];
double p[300][300];
int vis[300];
double d[300];
/*void dij(int z)
{
    fill(d,d+300,INF);
    memset(vis,0,sizeof(vis));
    d[z]=0;
    per(i,1,n)
    {
    	int minn=INF,k;
    	per(j,1,n)
    	{
    		if(vis[j]==0&&d[j]<minn)
    		{
    			k=j;
    			minn=d[j];
			}
		}
		vis[k]=1;
		per(j,1,n)
		{
			/*if(vis[j]==0&&p[k][j]!=INF&&d[k]+p[k][j]<d[j])
			{
				d[j]=d[k]+p[k][j];
			}
			d[j]=min(d[j],max(d[k],p[j][k]));
		}
	}
}*/
void spfa()
{
    queue<int>q;
    fill(d,d+300,INF);
    d[1]=0;
    for(int i=1; i<=n; i++)
        vis[i]=0;
    vis[1]=1;
    q.push(1);
    while(!q.empty())
    {
        int k=q.front();
        vis[k]=0;
        q.pop();
        for(int j=1; j<=n; j++)
            if(max(d[k],p[k][j])<d[j])
            {
                d[j]=max(d[k],p[k][j]);
                if(vis[j]==0)
                {
                    q.push(j);
                    vis[j]=1;
                }
            }
    }
}
int main()
{
    int k=1;
    while(~scanf("%d",&n)&&n!=0)
    {
        memset(p,0,sizeof(p));
        memset(vis,0,sizeof(vis)); 
        per(i,1,n) scanf("%d%d",&s[i].x,&s[i].y);
        per(i,1,n)
            per(j,i+1,n)
            {
				p[i][j]=p[j][i]=sqrt(double(s[i].x-s[j].x)*(s[i].x-s[j].x)+double(s[i].y-s[j].y)*(s[i].y-s[j].y));
			}
        spfa();
        //per(i,1,n) cout<<d[i]<<"*";
        printf("Scenario #%d\nFrog Distance = %.3lf\n\n",k++,d[2]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/PleasantlY1/article/details/82462509
今日推荐