20-1-11-最短路的变形&&SPFA实现-POJ2253

SPFA算法介绍](https://blog.csdn.net/strve/article/details/80957491)

Frogger

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 76058 Accepted: 23140

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists’ sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona’s stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog’s jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy’s stone, Fiona’s stone and all other stones in the lake. Your job is to compute the frog distance between Freddy’s and Fiona’s stone.

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy’s stone, stone #2 is Fiona’s stone, the other n-2 stones are unoccupied. There’s a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying “Scenario #x” and a line saying “Frog Distance = y” where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

Source

Ulm Local 1997

将SPFA的松弛条件更改即可

#pragma warning(disable:4996)
#include<cstdio>
#include<iostream>
#include<vector>
#include<queue>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;

/*
* 单源最短路SPFA
* 时间复杂度0(kE)
* 这个是队列实现,有时候改成栈实现会更加快,很容易修改
* 这个复杂度是不定的
*/
const int MAXN = 2005;
const int INF = 0x3f3f3f3f;

struct Edge {
	int v;
	double cost;
	Edge(int _v = 0, double _cost = 0) :v(_v), cost(_cost) {}
};

vector<Edge>E[MAXN];

void addEdge(int u, int v, double cost) {
	E[u].push_back(Edge(v, cost));
}
queue<int>q;
bool vis[MAXN];		//顶点i是否在队列中
int cnt[MAXN];		//顶点i进入队列的次数
double dist[MAXN];		//顶点start到顶点dist的最小的跳远距离
bool SPFA(int start, int n) {
	memset(vis, false, sizeof(vis));
	memset(cnt, 0, sizeof(cnt));
	for (int i = 1; i <= n; i++) {
		dist[i] = INF;
	}
	dist[start] = 0;
	q.push(start);
	vis[start] = true;
	cnt[start] = 1;
	while (!q.empty()) {
		int u = q.front();
		q.pop();
		vis[u] = false;
		for (int i = 0; i < E[u].size(); i++) {
			int v = E[u][i].v;
			if (dist[v] > max(E[u][i].cost, dist[u])) {
				dist[v] = max(E[u][i].cost, dist[u]);
				//cout << E[u][i].cost << " " << dist[u] << " " << E[u][i].cost << endl;
				if (!vis[v]) {
					vis[v] = true;
					q.push(v);
					if (++cnt[v] > n) {
						return false;
					}
				}
			}

		}
	}
	return true;
}

struct Point2 {
	int x, y;
	Point2(int _x = 0, int _y = 0) :x(_x), y(_y) {}
};
Point2 point[MAXN];

inline double dis(const Point2& a, const Point2& b) {
	return sqrt(double((a.x - b.x) * (a.x - b.x) + (a.y - b.y) * (a.y - b.y)));
}

int main() {
	int n;
	int a, b;
	int time = 0;
	while (scanf("%d", &n) && n) {
		while (!q.empty()) {
			q.pop();
		}
		for (int i = 1; i <= n; i++) {
			E[i].clear();
		}
		for (int i = 1; i <= n; i++) {
			scanf("%d%d", &point[i].x, &point[i].y);
		}
		for (int i = 1; i <= n; i++) {
			for (int j = i + 1; j <= n; j++) {
				double d = dis(point[i], point[j]);
				addEdge(i, j, d);
				addEdge(j, i, d);
			}
		}
		SPFA(1, n);
		printf("Scenario #%d\nFrog Distance = %.3lf\n\n", ++time, dist[2]);
	}
}
发布了21 篇原创文章 · 获赞 8 · 访问量 2730

猜你喜欢

转载自blog.csdn.net/shen253135371/article/details/103942454