POJ2253-Frogger(最短路径)

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone.

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input
2
0 0
3 4
3
17 4
19 4
18 5
0
Sample Output
Scenario #1
Frog Distance = 5.000
Scenario #2
Frog Distance = 1.414

思路:改进floyd(),找最小路中的最大值

if(cost[i][j]>max(cost[i][k],cost[k][j]))
                        cost[i][j]=max(cost[i][k],cost[k][j]);

注意:cost[i][j]数组处理

//题目意思就是求所有路径中最大值中的最小值。
#include<iostream>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
//(Floyd-Wrashall算法)(求任意两点之间的最小距离)
const int MAX=210,INF=0x3f3f3f3f; 
float cost[MAX][MAX];//cost[i][j]表示顶点i到顶点j的权值
int V;//顶点数 
void floyd(){
	for(int k=1;k<=V;k++) {
		for (int i=1;i<=V;i++) {
			for (int j=1;j<=V; j++) {
				cost[i][j]=min(cost[i][j], cost[i][k] + cost[k][j]);
				if(cost[i][j]>max(cost[i][k],cost[k][j]))
                        cost[i][j]=max(cost[i][k],cost[k][j]);
			}
		} 
	} 
}
struct name{
	double x;
	double y;
}add[MAX]; 
int main(){//转化为权值成为难点 ,只是已知点的坐标 
	int n,k=1;
	add[0].x=add[0].y=0;
	while(1){
		cin>>n;
		V=n;
		if(n==0)
			break;
		else{
			for(int i=1;i<=n;i++){
				cin>>add[i].x>>add[i].y;
			}
		}
		memset(cost,INF,sizeof(cost));
		for(int i=1;i<=n;i++)
			for(int j=i+1;j<=n;j++){
				cost[i][j]=cost[j][i]=sqrt((add[i].x-add[j].x)*(add[i].x-add[j].x)+(add[i].y-add[j].y)*(add[i].y-add[j].y));
				//cout<<cost[i][j]<<" ";
			}
		floyd();
		cout<<"Scenario #"<<k++<<endl<<"Frog Distance = ";
		printf("%.3f\n\n",cost[1][2]);//cout<<cost[1][2]<<endl;
	}	
}
发布了73 篇原创文章 · 获赞 27 · 访问量 1224

猜你喜欢

转载自blog.csdn.net/queque_heiya/article/details/103927511