hdu-1506-直方图

Largest Rectangle in a Histogram

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 20738    Accepted Submission(s): 6319


Problem Description
A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:

Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.
 

Input
The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, ..., hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.
 

Output
For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.
 

Sample Input
 
  
7 2 1 4 5 1 3 3 4 1000 1000 1000 1000 0
 

Sample Output
 
  
8 4000
 

Source

University of Ulm Local Contest 2003

最大子矩阵的面积

#include<stdio.h>
#include<string.h>
long long a[100005],l[100005],r[100005];
int main()
{
	int n,i;
	long long t,max;
	while(~scanf("%d",&n)&&n)
	{
		memset(r,0,sizeof(r));
		memset(l,0,sizeof(l)); 
		max=-1;
		for(i=1;i<=n;i++)
		scanf("%d",&a[i]);
		l[1]=1;r[n]=n;
		for(i=2;i<=n;i++)
		{
			t=i;
			while(t>1&&a[i]<=a[t-1])
			t=l[t-1];
			l[i]=t;
		}
		for(i=n-1;i>=1;i--)
		{
			t=i;
			while(t<n&&a[i]<=a[t+1])
			t=r[t+1];
			r[i]=t;
		}
		for(int i=1;i<=n;i++)
		{
			t=(r[i]-l[i]+1)*a[i];
			if(t>max)
			max=t;
		}
		printf("%lld\n",max);
	}
}


猜你喜欢

转载自blog.csdn.net/qq_36914923/article/details/80069918
今日推荐