hdu1506

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:
在这里插入图片描述
Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.
Input
The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1<=n<=100000. Then follow n integers h1,…,hn, where 0<=hi<=1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.
Output
For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.
Sample Input
7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0
Sample Output
8
4000
Hint
Huge input, scanf is recommended.

这个题目大意就是让你求从一个位置向左右能扩展的最大宽度,通过“两个”递减的单调队列来求出左右边界为了使每个数都能入队出队需要先将a[0],a[n+1]初始化。

#include <iostream>
#include <cstdio>
#include <string.h>
#include <string>
#include <cmath>
#include <algorithm>
#include <cstdio>
using namespace std;
long long int a[1000009];
int n,l[1000009],r[1000009],k[1000009];
void llmax()
{
    k[0]=0;
    int lef=0,ri=1;
    for(int i=1;i<=n;i++)
    {
        while(lef<ri&&a[i]<=a[k[ri-1]])ri--;
        l[i]=i-k[ri-1]-1(k[ri-1],的位置并不属于要扩展的位置所以要减去);
        k[ri++]=i;//一边构造单调队列一边进行左右边界的判断
    }
}
void llmin()
{
    k[0]=n+1;
    int lef=0,ri=1;
    for(int i=n;i>=1;i--)
    {
        while(lef<ri&&a[i]<=a[k[ri-1]])ri--;
        r[i]=k[ri-1]-i-1;
        k[ri++]=i;
    }
}
int main()
{
    while(~scanf("%d",&n),n!=0)
    {
        for(int i=1;i<=n;i++)
            scanf("%lld",&a[i]);
            a[0]=a[n+1]=-1;//初始化边界。
        llmax();
        llmin();
        long long int maxn=-1;
        for(int i=1;i<=n;i++)
        {
            long long int x=(l[i]+r[i]+1)*a[i];
            if(x>maxn)
                maxn=x;
        }
        printf("%lld\n",maxn);
    }
}

猜你喜欢

转载自blog.csdn.net/u013345179/article/details/90141658
今日推荐