Largest Rectangle in a Histogram//HDU - 1506

Largest Rectangle in a Histogram//HDU - 1506


题目

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:

Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.
Input
The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, …, hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.
Output
For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.
Sample Input
7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0
Sample Output
8
4000
题意
给你条形图,求最大矩形面积

思路

l数组表示该点可计算入矩形直到左边某点为止,r数组同理

代码

#include <cstdio>
#include <cstring>
#include <string>
#include <iostream>
#include <algorithm>
#include <deque>
#include <queue>
#include <stack>
#include <cmath>
#define pi 3.1415926
using namespace std;
typedef long long ll;
const ll inf=100000000000;
ll num[100100],l[100100],r[100100];

int main()
{
    int n;
    while (scanf("%d",&n)!=EOF&&n) {
        memset(l,0,sizeof(l));
        memset(r,0,sizeof(r));
        memset(num,0,sizeof(num));
        for (int i=1;i<=n;i++)
            scanf("%lld",&num[i]);
        l[1]=1;r[n]=n;
        for (int i=2;i<=n;i++) {
            int t=i;
            while (t>1&&num[i]<=num[t-1])
                t=l[t-1];
            l[i]=t;
        }
        for (int i=n-1;i>=1;i--) {
            int t=i;
            while (t<n&&num[i]<=num[t+1])
                t=r[t+1];
            r[i]=t;
        }
        ll ans=0;
        for (int i=1;i<=n;i++)
            ans=max(ans,(r[i]-l[i]+1)*num[i]);
        printf("%lld\n",ans);
    }
    return 0;
}

注意

发布了50 篇原创文章 · 获赞 19 · 访问量 2575

猜你喜欢

转载自blog.csdn.net/salty_fishman/article/details/104516439